Jump to content
  • 0

Failed to load DX9 DLL



I'm trying to run the game from Steam on Vista, but immediately after clicking it, I get an error message saying "Failed to load DX9 DLL" and nothing more. Here are some things that I've tried (multiple times in various orders and combinations):


Validated the cache

Checked Steam betas are deactivated

Checked Steam client is up to date

Deleted the Steam appcache folder

Installed the DX9 and VC redists from the game folder (both with and without Steam running, and deleting appcache afterwards)

Installed DX9 June 2010 SDK (which required VC runtime to be rolled back, then reinstalled afterwards)

Uninstalled VC runtime bundled with Visual Studio 2010

Jumping up and down and swearing


Please help. I've paid for this game and now I just want to be able to play it. Thanks!

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 0

I would try going to the engine.ini file, open with notepad, then look for dx11 and use dx 11 option, set tose to true, and dx 9 to false, should force it to work in dx11 and fix problem. Thats what I am using it in. But heads up if you verify cache after that it will set back to original settings. 

Link to comment
Share on other sites

  • 0

Today I also tried completely uninstalling DX9 and VC redists, as well as Visual Studio just in case, deleting local content, restarting my machine, re-downloading the game, re-installing DX9 and VC redists then retrying. Same problem....

Link to comment
Share on other sites

  • 0

Thanks astherial, I gave that a shot and also edited the config.ini ... but no luck. It still says "failed to load DX9 DLLs" even when DX11 is set. WEIRD. Here are my ini's...



; Win32 engine defaults configuration file

default_brightness = 0.138000
default_contrast = 0.946001
default_gamma = 2.2
default_contrast_range_low = 0.09
full_screen = 1
full_screen_width = 0  ; 0 -> desktop width
full_screen_height = 0 ; 0 -> desktop height
window_width = 1280
window_height = 720
adapter = -1 ; -1 -> primary
shadow_quality = 2 ; 0:25%, 1:50%, 2:100%, 3:200%, 4:300%, 5:400%, 6:800%
msaa = 1  
support_aspect_ratio_4_3 = true
support_aspect_ratio_16_10 = true
support_aspect_ratio_custom = true
default_display_conversion = box ; box|stretch|crop
dist_fade_duration = 0.5 ; time it takes for something to fade once the range is reached
dist_fade_in_range = 40.0 ; distance from camera that the object will begin to fade back in at.
dist_fade_out_range = 45.0 ; distance from camera that the object will begin to fade out at.
s3d_ar_multiplier = 1.3 ; aspect ratio multplier used to adjust the culling frustum for 3D.
use_directx_11 = true ; false=DX9, true=DX11

enabled  = 1
enable_communication  = 1

ragdolls_enabled  = 1

preferred_device = gamepad

project_name  = Onyx
npc_chatter_cooldown  = 3.0
creature_chatter_cooldown  = 4.0
; Application override configuration file

default_gamma = 1.0
full_screen = 1
shadow_quality = 3
support_aspect_ratio_4_3 = false
support_aspect_ratio_16_10 = false
support_aspect_ratio_custom = false
use_directx_11 = true
separate_dimensions = 1
support_skinning = false

; render post-process settings
enable_postprocess                      = true
enable_depth_of_field                   = false
enable_bloom                            = false
enable_antialias                        = false
enable_color_correction                 = false
enable_color_controls = false
enable_fog = false
enable_heat_haze                        = true
enable_transparent_depth  = false
motion_blur_enable                      = false
motion_blur_scale                       = 0.5
motion_blur_max_length                  = 0.3
movie_sharpen_amount = 0.0
movie_sharpen_radius = 0.0
scaleform_edge_aa                       = 1.0

; perf_marker_categories_enabled is a bit field. The value defs
; are in oei_perf_marker.h.
perf_marker_categories_enabled = 0
log_disc_access = false

project_name = South Park - The Stick of Truth
demo_mode = false
disable_warnings = false

listener_offset = 8.0
listener_separation = 16.0

clip_to_screen = false
use_hardware_mouse = true

curve_tolerance = 3.0
collinearity_tolerance = 3.0
skip_single_node = false

Anything else I could try? Thanks!

Link to comment
Share on other sites

  • 0

Thanks astherial! The error message I was getting gave no further info, just "failed to load..."


But... whilst I trying to run in compatibility mode I launched from the folder instead of the Steam client and I got a separate error message. It said that d3dx11_43.dll was corrupted.


So I unzipped all the x86 cabs in the redist folder, found d3dx11_43.dll and, sure enough, the version in my System32 folder was older - guess the DX9 installer must have skipped it.


Copied it over manually and voila! Glad it's working now, coz I'd just about lost patience. Hope the game is as good as I've been expecting, to make up for this nonsense.


Cheers!  :biggrin:

Link to comment
Share on other sites

  • 0

Same issue. Unable to enjoy my purchase. As a programmer I spend enough time resolving issues already. I will not do that on my free time when I have paid and can expect working product out of the box. I will request refund in few days from steam.

Link to comment
Share on other sites

  • 0

Well, I did spend time investigating contrary to my previous comment. I posted solution in the Steam community but I will add it here to as well.


Game tries to install VC Redist packages which can fail when newer versions are already installed. Uninstall latest packages with commands:

MsiExec.exe /passive /X{F0C3E5D1-1ADE-321E-8167-68EF0DE699A5}
MsiExec.exe /passive /X{1D8E6291-B0D5-35EC-8441-6616F567A0F7}

And then relaunch the game


Not ideal solution as you will be out of couple possibly required packages for other games. They can be installed afterwards again on top of SP: SOT, but I have really no interest digging out those ATM ...

  • Like 1
Link to comment
Share on other sites

  • 0

BTW, although I was nearly out of patience, I'm enjoying the game and glad I persevered. I'm a programmer too (indie game developer) and I have an Xbox as well as being a PC gamer. I agree that when you pay for something you expect it to work out of the box, but in a perverse sort of way I've always kind of enjoyed the challenge of getting PC games to work. It all started back in the DOS days of freeing up base memory and creating boot disks just to be able to run Doom.


I dunno, maybe I'm a masochist or something!

  • Like 1
Link to comment
Share on other sites

  • Create New...