Jump to content
Sign in to follow this  
SickOfThisBS

Mouse Acceleration

Recommended Posts

Why.... in g0d's name is Mouse acceleration forced? Why? I honestly don't get it. Why?

 

It's possible to disable it in all other UE3 games, but not in this special title. Please, look on google, see how much bEnableMouseSMoothing comes up and what people are annoyed with.

 

This is a game breaker for people with history in games such as Q2, Q3, Wolf, etc. Didn't that cross your mind you..FREAKING GENIOUSES at Obsidian? That MAIN PERIPHERAL ON PC IS MOUSE? That mouse = precision? That PC is NOT a console and that people buy PC games instead of console versions for a reason?

 

It's no wonder you were delayed 6 months. They should have canceled this bugfest.

 

And please don't mention an xbox controller to me. You can shove that thing up your ass.

 

What an epic fail. Over and out.

Edited by SickOfThisBS

Share this post


Link to post
Share on other sites

What exactly is your complaint? Mouse is too slow?

 

I take it you've checked the .ini files to see if you can edit the string?

Share this post


Link to post
Share on other sites

He means that mouse scroll speed increases as you move the mouse and you can't disable this. I think.


"Bones heal, chicks dig scars, pain is temporary, glory is forever."

What is glass but tortured sand?
Never forget! '12.01.13.

Share this post


Link to post
Share on other sites
What exactly is your complaint? Mouse is too slow?

 

I take it you've checked the .ini files to see if you can edit the string?

 

My post was targeted at any developers at Obsidian in case they check this forum, which I doubt, but I'll clarify for others who might search for issues relating to mouse.

 

The problem is that when a UE3 variable named bEnableMouseSmoothing is enabled, a sudden change in FPS while the player is moving the mouse results in a large jump of the mouse resulting in an extremely imprecise mouse control.

 

This is generally NOT a good thing for shooters.

 

It is possible to edit the <gamename>Input.ini files in all other UE3 based games and change this variable value to FALSE so that this does not occur and the mouse remains precise despite any frame rate fluctuations. However this cannot be done in Alpha Protocol because this variable is hard-coded and cannot be changed via configuration files.

Share this post


Link to post
Share on other sites

They do check the forum, for instance Josh and Alvin have been around for hours earlier today.

 

Anyway, I don't have the game yet but that does sound rather silly - if it's editable for other UE3 games I wonder why it was hardcoded? Sounds like something we can hopefully get an official or fanmade fix for sooner or later, if lots of other people are suffering from it.

 

I assume fiddling mouse settings in control panel will have minimal effect?

Share this post


Link to post
Share on other sites
They do check the forum, for instance Josh and Alvin have been around for hours earlier today.

 

Anyway, I don't have the game yet but that does sound rather silly - if it's editable for other UE3 games I wonder why it was hardcoded? Sounds like something we can hopefully get an official or fanmade fix for sooner or later, if lots of other people are suffering from it.

 

I assume fiddling mouse settings in control panel will have minimal effect?

It is actually even worse than that. The mouse settings available ingame are only sensitivity, but the mouse input itself is utterly broken. The game runs perfectly fine as long as you don't touch the mouse. Smooth as butter. But as soon you try to turn (and aim) the camera begins skipping around like crazy. For me the game is flat out unplayable on the PC and i feel pretty ripped off over having paid full price.

 

Since the description i just gave may not be intuitively graspable for everyone, i'll be uploading a video on youtube demonstrating what i mean.

Share this post


Link to post
Share on other sites

Strange, wonder what the issue could be. On my friends computer, we had the problem of the mouse flipping around when a new section of the level loaded. But aside from that, the mouse worked just fine (had to tweak the sensitivity to my liking but that's no issue).

 

I hope SEGA will release patches to fix some of the issues people are having. I'm not sure what their track record on patching games are.


Listen to my home-made recordings (some original songs, some not): http://www.youtube.c...low=grid&view=0

Share this post


Link to post
Share on other sites
They do check the forum, for instance Josh and Alvin have been around for hours earlier today.

 

Anyway, I don't have the game yet but that does sound rather silly - if it's editable for other UE3 games I wonder why it was hardcoded? Sounds like something we can hopefully get an official or fanmade fix for sooner or later, if lots of other people are suffering from it.

 

I assume fiddling mouse settings in control panel will have minimal effect?

 

I really do hope they read and that SEGA allows them to fix something as trivial as this, along with other issues. I knew this game isn't gonna be an AAA title but it looked like it had a soul. However being slapped with broken mouse control which is essential in PC games...of all things.

 

It's funny to go on a nerd rage like I did, but good games are few and far in between these days. At least for me. I'm disappointed after all this wait.

 

And to answer the Control Panel question..No. The settings there are set in stone and work flawlessly in games that pay full attention to mouse as the primary input method on the PC platform so it's a no no to change them because of one game that's off the axis.

Share this post


Link to post
Share on other sites

In DefaultInput.ini and APInput.ini, set bEnableMouseSmoothing to equal FALSE. See if it has an effect.

 

EDIT: Might want to write-protect those files, in case the game tries to force it.

Edited by Jerkoj

Share this post


Link to post
Share on other sites

go to mydocuments\alpha protocol\apgame\config\apinput.ini and edit the bEnableMouseSmoothing=true to bEnableMouseSmoothing=false and that should fix your problem.

 

PS. the directory structure may be documents\alpha protocol\apgame\config\apinput.ini instead in Windows Vista and this is all either under your username in users or documents and settings depending on whether or not you are using Windows XP, Vista, or Windows 7. (in order)

Edited by guenthar

Share this post


Link to post
Share on other sites

This is what he posted guys, I'm guessing he already tried it:

 

It is possible to edit the <gamename>Input.ini files in all other UE3 based games and change this variable value to FALSE so that this does not occur and the mouse remains precise despite any frame rate fluctuations. However this cannot be done in Alpha Protocol because this variable is hard-coded and cannot be changed via configuration files.
Edited by Starwars

Listen to my home-made recordings (some original songs, some not): http://www.youtube.c...low=grid&view=0

Share this post


Link to post
Share on other sites

That's why I added the read-only part. Because when I did that, it seemed to have an effect. Or maybe I'm imagining things.

Share this post


Link to post
Share on other sites
go to mydocuments\alpha protocol\apgame\config\apinput.ini and edit the bEnableMouseSmoothing=true to bEnableMouseSmoothing=false and that should fix your problem.

This does nothing. Here's how the problem looks like:

 

That's why I added the read-only part. Because when I did that, it seemed to have an effect. Or maybe I'm imagining things.

I'm sorry, you are. The game does not even try to change those.

Edited by Mithaldu

Share this post


Link to post
Share on other sites
Why.... in g0d's name is Mouse acceleration forced? Why? I honestly don't get it. Why?

 

It's possible to disable it in all other UE3 games, but not in this special title. Please, look on google, see how much bEnableMouseSMoothing comes up and what people are annoyed with.

 

This is a game breaker for people with history in games such as Q2, Q3, Wolf, etc. Didn't that cross your mind you..FREAKING GENIOUSES at Obsidian? That MAIN PERIPHERAL ON PC IS MOUSE? That mouse = precision? That PC is NOT a console and that people buy PC games instead of console versions for a reason?

 

It's no wonder you were delayed 6 months. They should have canceled this bugfest.

 

And please don't mention an xbox controller to me. You can shove that thing up your ass.

 

What an epic fail. Over and out.

 

So.. just as a note, if you are gonna go on an angry rage about something like that, cursing, bolding, and capslocking, and particularly insulting the intelligence of others, at LEAST spell the word GENIUSES right.... :lol:

Share this post


Link to post
Share on other sites

Hm, I haven't had any sort of trouble like that with my mouse while playing... Sure I'm playing a lot of stealth and hand to hand.. but I've also been using a fair bit of pistol and assault rifle without too much grief..


"Cuius testiculos habeas, habeas cardia et cerebellum."

Share this post


Link to post
Share on other sites

I don't have the game but from looking at the youtube video that looks like a common problem with games developed for console and poorly ported to PC. This kind of problem is just one of many symptoms I collectively refer to as 'Consolitus' issues :-

 

I suspect that mouse turning problem is due to poor implementopn of mouse input code. It looks like the mouse inputs are just being directly routed to code that is purely designed for an Xbox360 controller. Anyone who has used a console controller knows that when you turn, you turn at a constant speed so the controller code in the game is designed around that.

 

A mouse being moved by a human hand however is bound to produce non-constant speed motion. In these situations I suspect what's needed is for completely different code to handle PC input devices rather than having Xbox360 controller code being force-fed mouse inputs.

 

I'm surprised an Obisidan game is suffering from this considering this fine developer cut it's teeth on PC only titles.

 

Something else to try is to set all your visual settings to absolute minimums to see if the problem persists. If it vanishes then it suggests that the problem is, in whole or part, due to the game engine not handling its resources very well, such as textures loading, enemy spawning etc, which can compound the issue further.

Edited by darrenecm

Share this post


Link to post
Share on other sites

I just registered to tell the OP this. I haven't got the game yet. but I too am a pc gamer who hates mouse acceleration in games (dead space, assassin's creed 2, I'm looking at you!). But I found a fix searching on google. It basically alters a line in the registry, preventing windows from responding to mouse acceleration, regardless of whther its been harcoded into a game or not.created by a user called "cheese" search for "cheese's mouse fix" or "cheesemfix". it comes with an alternative method. Though cheese's much better. and is reversible, without the need of rebooting orr anythig. just click and enjoy.

Share this post


Link to post
Share on other sites
I just registered to tell the OP this. I haven't got the game yet. but I too am a pc gamer who hates mouse acceleration in games (dead space, assassin's creed 2, I'm looking at you!). But I found a fix searching on google. It basically alters a line in the registry, preventing windows from responding to mouse acceleration, regardless of whther its been harcoded into a game or not.created by a user called "cheese" search for "cheese's mouse fix" or "cheesemfix". it comes with an alternative method. Though cheese's much better. and is reversible, without the need of rebooting orr anythig. just click and enjoy.

 

Thanks, I'll check it out.

 

Ok, checked it out. While it didnt completely disable the crazy mouse issues, it reduced the times it occured.

Edited by blackwolfe

Share this post


Link to post
Share on other sites

Changing the MinSmoothedFrameRate and MaxSmoothedFrameRate in the APEngine to 20 and 30 respectively does the job without having to edit reg. It is also reversible and reboot not required.

Share this post


Link to post
Share on other sites
Changing the MinSmoothedFrameRate and MaxSmoothedFrameRate in the APEngine to 20 and 30 respectively does the job without having to edit reg. It is also reversible and reboot not required.

 

Well, that didnt do it for me, but the reg key did.

Share this post


Link to post
Share on other sites
Changing the MinSmoothedFrameRate and MaxSmoothedFrameRate in the APEngine to 20 and 30 respectively does the job without having to edit reg. It is also reversible and reboot not required.

 

I think this fix applies to a different problem. There are two issues with mouse acceleration (or at least that seems to be the cause). One where there is a constant stutter whenever you use the mouse, one where the screen freezes for a fraction of a second, then turns you facing whatever direction.

 

The smoothedframerate fix is targeting the former, while the cheesemfix is targeting the latter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...