Jump to content

KOTOR II and WINDOWS 7 BLACK FRAMES


Recommended Posts

Hello, i ve just installed KOTOR TSL on my computer running on the following specs:

 

Intel Core Duo T8100 2.2

4GB DDR2 RAM

Nvidia GeForce 9500m GS

Windows 7 Ultimate x64

 

Here the problem, the game runs just like a CHARM. The only problem is its not on full screen. My native resolution is 1280 x 800 , and the in-game resolutions is at maximum which means is 1024 x 768. All the anti-alias settings and anistropic filterings are in highest, also all graphic details are set on maximum too.

I play the game smoothly but its not on full screen you can see the black frames at your left and your right. What can i do? I tried putting my native resolution to 1024 x 768 but still the frames are there.

 

What can i do?

If anyone wants more information just ask me.

Link to post
Share on other sites

I'm guessing you're trying to run the game in widescreen, to get rid of the black borders to the left and right of the screen, right? Unfortunately you can't, the game doesn't support it. I believe there is a mod that says it enables widescreen, but I don't think it works properly.

Link to post
Share on other sites

The game supports 1280x768 natively, but you'll have to open "swkotor2.ini" with Notepad and change the resolution to 1280x768 under both "Display Options" and "Graphics Options", then save and exit.

 

It would also be a good idea to enter the line "Disable Vertex Buffer Objects=1" under "Graphics Options" as well, and set CPU affinity to one core in Task Manager every time you launch the game.

Edited by Qliveur
Link to post
Share on other sites

It's also vaguely possible your monitor itself may have some option setting about how to display non-widescreen...w/black bars or 'stretched out' to fill screen. Mine does.

I personally dislike the stretched out look myself...

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites
The game supports 1280x768 natively, but you'll have to open "swkotor2.ini" with Notepad and change the resolution to 1280x768 under both "Display Options" and "Graphics Options", then save and exit.

 

It would also be a good idea to enter the line "Disable Vertex Buffer Objects=1" under "Graphics Options" as well, and set CPU affinity to one core in Task Manager every time you launch the game.

 

Btw, i tried that but doesnt do anything. I set the parameters in swkotor.ini in graphics option a larger resolution (also did the same in display options) but the result still the same. Does any of you guys can choose a larger resolution than 1024 X 768 ?

Link to post
Share on other sites

It goes to 1280x960 on my Win7...it used to go to 1600x1200 on XP w/a CRT monitor, but not on this 1920x1080 LCD...altho haven't bothered to try tweaking it. I'm guessing if you had an even bigger resolution LCD monitor the 1600x1200 would show up but I dunno.

 

I'm not using a laptop, either.

 

Any other options available?

Learn to not mind black bars on the side? :blush: Sorry, I have nothing. :/

Edited by LadyCrimson
“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites

Yeah, I don't think there's any real way of getting a widescreen option working smoothly; you either get the stretching (which can look awful), or mods that don't quite work properly (if you do get it working: I recall someone saying that the widescreen mod disabled the mini-map or something). You'll just have to put up with those black bars on the sides, I'm afraid.

Edited by refuse
Link to post
Share on other sites
  • 1 month later...
Yeah, I don't think there's any real way of getting a widescreen option working smoothly; you either get the stretching (which can look awful), or mods that don't quite work properly (if you do get it working: I recall someone saying that the widescreen mod disabled the mini-map or something). You'll just have to put up with those black bars on the sides, I'm afraid.

 

Though its old thread, I fixed it simple by going to folder where game is installed, opened swkotor2.ini and changed there resolution in 2 places to 1440x900, and it works perfectly.

Link to post
Share on other sites
  • 8 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...