Jump to content

Kotor 2 lag

Recommended Posts

Hi, my pc is having some issues with kotor 2.


Its a fairly old computer, but its far above maximum requirements. So It should run it smoothly in full detail without any hitches.


The problem Im having, is whenever I enter a new area in kotor 2, then it lags a lot. If I go into the graphics options and for example just slide the anti-aliasing or another feature on and off, and go back, then it runs smoothly until a new area.


How can I fix that so I dont have to go slide in the graphcis options everytime I enter a new area in the game?

Link to comment
Share on other sites

  • 1 month later...

I just registered to say that I have the exact same problem as above, and need help. I've tried reverting drivers and that made the game unplayable (crashing, had to reinstall it). While ingame if you just move the graphic slider back and then return it or wherever (it doesn't seem to matter) the lag goes away, but it's driving me nuts on why I had to do this every time I enter a new area.


I was told on another forum (gamefaqs) that it might have to do with the screen resolution not matching on my display with ingame, and everything is matched at 1024 x 768 resolution with 85 refresh rate. Help please!


My system specs are :



2 gigs ram

Geforce 6600 256mb

intel pentium 4 3.4ghz

Link to comment
Share on other sites

Turn off grass in the graphics options. If that doesn't work, open up the swkotor2.ini file with a text editor and add the line "Disable Vertex Buffer Objects=1" under the [Graphics Options] section.

Cry 'Havoc' and let slip the dogs of War!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...