Jump to content

KotOR2 will not start.

Recommended Posts

Hey guys i've been trying to get KotOR2 to run on my pc for a few days now and nothing i've done has worked.

(So you know my computer is running Vista, as is most of the people with the same or similar issue.)

I'll start from the beginning.

I installed the game like you would any other game, after the installsion I tried to play it and a message appeared saying.


'Microsoft Visual C++ Runtime Libary

Runtime Error!

Program C:\Program Files\LucasArts\SWKotOR2\swkotor2.exe

abnormal program termination'


I tried to reinstall it and as you probably guessed that didn't work.

I then searched ways of fixing this and came across the Mss32.dll issue.

So I downloaded the Mss32.dll which was meant to fix it, replaced it with the one in the

SWKotOR2 program folder and there was absolutely no change. It's still stufing up.

Went back to looking for information and read about contacting support@securom.com.

I contacted them and they said:


Right-click on the application's desktop shortcut or the actualapplication's executable file in the installation folder, and a menu will appear.

Choose 'Launch Analysis' from this menu.


There is no Launch Analysis in the menu bar.

Now I don't know if its because I don't have any SecuROM software (atleast I don't know if I do nor how to locate it)

or what. But I contacted them back and they sent me a sr0_forcer.exe.

They gave me steps on how to go about obtaining an AnalysisLog.sr0 file using the sr0_forcer.exe but the information and what to do/how to use the program

I find was not detailed enough.

They simpily stated:


'3. Ensure the window stays open and follow the instructions displayed

4. Start the SecuROM protected application

5. An analysis file (AnalysisLog.sr0) will be created and saved to the rootdirectory of your c:\ drive'


In the email.

The programs only information was:


'sr0_forcer information

The automatic .sr0 generation function is now enabled. Launch a

protected SecuROM application now, to generate the .sr0 file! Click OK

to disable the mechanism.'


Which I find hard to understand.

I sent them another message but they never replied back.


Can anyone help me out?

Link to comment
Share on other sites

Securom is the copy-protection that is used on the game. I don't have Vista on my computer, but maybe it's a matter of enabling administration rights? Have a look at here, perhaps some of the info there can help you generate the analysis file. Depending on the analysis file you provide Securom with, they will then supply you with a modified .exe of the game (i *think*) in order to get the game running. Unfortunately, only they can do that.

Link to comment
Share on other sites

Did you right-click on the correct executable/shortcut? If you right-clicked on the menu or desktop shortcut, it shouldn't have the launch analysis option, since the shortcut points to launcher.exe and not swkotor2.exe. You need to right-click directly on the swkotor2.exe file and the launch analysis option should be the third (or fourth) option on the menu.

Cry 'Havoc' and let slip the dogs of War!



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...