Jump to content

Recommended Posts

I'm sorry if this isn't clear enough. I have a straight FD-16 DVDROM16X. I velieve it a plug and play i'm not sure. I had for it bout three years now. on two different computers. But I have a problem that has plagued both my computers. Everytime put a disc in I have to manually start the disc either thru the icon or media play if a cd or movie. Or installing I have to go thru my computer explore the drive or disc and hit auto play. Additionly Most of my games i can only play once then i have to restart my computer top play it again my cd games are fine side the fact they won't auto play. I'm not sure what i need to post tell me and i will see what i can do.

Link to post
Share on other sites

You know, I just bought a brand new Dell for work and the same thing happens, no autostart when I put a CD/DVD in. I looked around at settings for like 10 whole seconds before I gave up and just navigate to it via the "run" command but Id like to know how to fix this too.

Link to post
Share on other sites

What OS are you using?

 

I still use XP so I dunno if Vista is different, but if I open Explorer and r-click on the DVD drive letter and select Properties, there's an Autoplay menu where you can choose what action you want to happen depending on the type of content. It seems mostly program related - ie, you can tell it to auto-open movie DVD's with Nero or auto-open music files with WinAmp. By default, it has a "Prompt Me For Action" selected.

 

I don't think this specifically affects games or install programs that try to self-auto-start, tho ... but I've never tried messing with it much, since I've never had a problem with those not starting.

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites

I really hate the autoplay and auto indexing features, It slows your computer to a crawl whenever there is a disk in the drive and you enter windows explorer by spinning up the drive all the time. On top of the slowdowns it's noisy and uses power for no reason at all.

 

If there is a way to get rid of it I would like to know.

Na na  na na  na na  ...

greg358 from Darksouls 3 PVP is a CHEATER.

That is all.

 

Link to post
Share on other sites

That rarely happens to me, during general CD use, either, so I'm not sure.

I think in that menu I was talking about there's a "take no action" option...maybe if you set everything to that, it then wouldn't even open Explorer or otherwise try to prompt you for an action.

 

Course, then I'd guess you have to also make sure the programs you use aren't set to auto-play the extensions they're programmed to associate with, if any.

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites

I actually use autoplay to give my harddisk-drives a nice icon via a autorun.inf :lol: You could go so far as to superficially protect your drives or iirc even folders by giving them icons suggesting they're something else and an autostart property that will cause e.g. Word to launch instead of the folder to open when someone double clicks them :)

 

 

Anyway:

Turning indexing off (Win XP):

Open My Computer. Rightclick on the harddisk icon you want to disable indexing for -> properties -> uncheck the box "index drive for faster searching" (or similar, I've got a german OS).

CD / DVD drives do not offer indexing and thus not this feature.

 

Turning Autoplay on / off (Win XP):

Open My Computer. Rightclick on drive icon you want to change autoplay settings for -> autoplay (tab). Change the settings to whatever you like. Iirc the system will check for the disk inserted non the less, it just won't autostart.

Edited by samm

Citizen of a country with a racist, hypocritical majority

Link to post
Share on other sites
Iirc the system will check for the disk inserted non the less, it just won't autostart.

The disk will still spin and the HD light may briefly come on as it checks what type of disc it is or whatever it's doing, but as long as Windows doesn't actually try to take an action/prompt you/open a window etc, it's never bothered me as "interference". But I don't usually try to insert discs while I'm in the middle of a lot of other things.

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites

So are you using XP?

 

Going to MS's site and searching "AutoRun" the first thing they recommend is making sure it's turned on:

Method 2: Make sure that AutoPlay is turned on

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

The AutoPlay feature may not be turned on. To turn on AutoPlay, follow these steps:

 

1. Click Start, and then click Run.

2. Type regedit, and then click OK.

3. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

4. Double-click Autorun and see whether a zero or a one is displayed in the Value data box.

* If the value for Autorun is 1, go to step 5.

* If the value for Autorun is 0, right-click Autorun, and then click Modify. In the Value data box, type 1, and then click OK.

5. Locate and then click the following subkey:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

6. Double-click NoDriveTypeAutoRun to see its value. If the value is 0xb5, the AutoRun feature for CD-ROMs is turned off. To turn on the AutoRun feature, follow these steps:

1. Right-click NoDriveTypeAutoRun.

2. Click Modify.

3. In the Value data box, type 91.

4. Select Hexadecimal, and then click OK.

7. Exit Registry Editor.

 

Test to determine whether the issue is resolved. If the issue is resolved, you are finished.

 

Another possibility regarding XP user rights:

The Autorun.inf file and the programs that the Autorun.inf file is designed to run may not run if you are logged on to Windows XP as a user without either Power User or Administrator rights.

 

By default, only users who are logged on to Windows XP with Power User or Administrator rights are allowed to install software. In Windows XP, files that have an .inf extension are considered to be setup information files. As a result, the Autorun.inf file does not run if you do not have Power User or Administrator rights.

 

 

There's also a possible issue w/a program called Easy CD Creator.

 

There's also a download called autofix.exe that can check for errors in autorun and maybe fix it, but I won't vouch for it, even if it is made by MS. You'll need the MS verification to download it from MS' official site etc.

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites

You can't really associate a program with autorun.inf, because it's a kind of autoexec(utable) associated with the current disc, which is triggered each time the disc is read. There is just a switch somewhere, that can be turned on or off for reading the autorun.inf or not.

 

There is a neat litle tool called Tweak UI which is a PowerToy for Windows XP, which will give you easy access to a of options, which sometimes can be a little hard to find.

 

There is a section under My Computer called Autoplay, where you can assign drives, types and handlers. Maybe you need to enable a few things here or there. >_<

Link to post
Share on other sites
You can't really associate a program with autorun.inf, because it's a kind of autoexec(utable)
this is incorrect, it's a plain text file. It contains information about what to run, what icons to use etc.

*.inf files normally are setup information files, but still they're just text :rolleyes:

Citizen of a country with a racist, hypocritical majority

Link to post
Share on other sites
Well my problem seems to be related to the dvdrom i had in. i brought a lite on off of newegg. just got it today. installed it and it's working like a champ.

That was going to be the thing I suggested next for Giftd...a dvdrom hardware/driver/compatibility issue. Sometimes it's a good idea to swap out the hardware to see if that's it, before going to too much other diagnostic trouble.

“Things are as they are. Looking out into the universe at night, we make no comparisons between right and wrong stars, nor between well and badly arranged constellations.” – Alan Watts
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...