Jump to content

KotOR 2 and sound on XP

Recommended Posts

I posted this same message (heartfelt cry for help) in the LucasArts forum but this forum seems a lot more active...


I have to disable sound to get KotOR 2 to load up and run. If I do not disable sound, then I see the mouse arrow icon turn to an arrow icon with an hourglass for a second, and then nothing except swkotor2.exe is listed in the processes of task manager.


I have upgraded to 1.02b, and installed the HQ music and movie files. However, this problem existed with the non-updated executable.


I have also tried copying mss32.dll (Miles Sound System?) from my KotOR 1 directory to my KotOR 2 directory (as suggested in various places around the net) which did not fix the problem. I also tried using the 'Force Software Sound' option which did not fix the problem. I have also selected all four settings of Audio Hardware Acceleration under the Windows Audio Advanced Properties tab. None of the four worked.


I have a Dell XPS m1710 w/ a GTX 7950 and the latest Dell approved nVidia driver for the 7950. The XPS laptop uses a Sigmatel audio chip, and I don't know the driver version, but I'm not changing it since the other 100 or so installed games work fine (including Neverwinter Nights 2 and expansion pack which was also developed by Obsidian using the same game engine). The machine is running XP MCE with SP2 and DirectX is 9.0c.


Does anyone know a way to get sound back on a machine configured similar to mine running XP? The game isn't as much fun without sound and not near as impressive.


And it's frustrating that my hardware which runs everything from DOS games under DosBox through the Wing Commander series to Warcraft 3 to Bioshock, can't run this game with sound. I hate to point fingers, but that doesn't seem like my fault or Dell's fault or Sigmatel's fault.


Please help...and please don't ask me to put (3) pages worth of system info up on this thread. I will not update drivers since I have games with release dates on either side of KotOR 2 that work fine.


The problem is with the game trying to initialize its sound system on my hardware. I'm just hoping someone else figured out a workaround (some obscure .ini setting) besides the mss32.dll copy trick (which seems primarily intended for Vista).


Thanks for any help,


Link to comment
Share on other sites

Strange usually importing that.dll file sorts this problem out straight away (I had this same problem when first playing the game on Vista).


This solution may seem simple but humor me, go in to your swkotor2.ini file and check all the sound options (it may be something as ridiculous as that).


Another possible solution is the dreaded reinstall but I assume you have tried this already...


Also try cracking your game (I doubt this will work though as that mainly fixes problems with people who can't get the executable to function properly, But it's worth a shot)


It's hard to assess these types of issues as these are usually because of a problem at "the other end" opposed to known issues with the game itself- Sorry i can't be any more help!

Link to comment
Share on other sites

Thank you for replying.


I did try re-installing, and I tried using both the 1.0 and 1.02b cracks. Normal executables with disc in drive and cracked executables all behaved the same.


I had great hope for the mss32.dll but I believe that's a Vista fix due to the way Vista does sound.


Perusing the forums, I've seen a couple of folks with the same problem although it looks like they haven't connected it to sound yet. One person had a Dell E1705 which probably uses the same sound chip as my m1710.


It's just irksome that I can make Longbow 2 and Interstate '76 and Wing Commander: Prophecy (which weren't even designed for XP) to run on my machine with sound and movies enabled, but I can't get this game which is relatively modern to run with sound. Out of all the other games I've tried on my laptop, only Crimson Skies won't run right (which is an nVidia driver problem which nVidia has no interest in fixing), and NOX won't run with movies but that's not very surprising since many late 90's games have very suspect compatibility with XP.


I realize that it's a combination of my hardware and the game, but I'm sure I'm not the only person who's tried to play KotOR 2 with a Dell laptop using a Sigmatel audio chip. And the LucasArts support forum mentions the same problem with the Soundblaster 16 (I think) and recommends different drivers. I may try that and hopefully not break compatibility with other games, but Sigmatel audio drivers are few and far between.


I thought DirectX was supposed to fix all this...


And by the way, any specific .ini settings that I should look at? I've already messed with the couple that correspond to the launcher's sound configuration with no luck.


I may also try installing it to my local drive since I'm currently playing it off an external drive. Maybe that will help...

Edited by IWantMyMTV
Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...