Jump to content
Bass-GameMaster

"How To" KOTOR 2 On Vista

Recommended Posts

Ah...I haven't tried KOTOR1 on this thing yet. :)

I take it the above steps didn't work for you on that one, then?

 

Not with Steam, for some strange reason.


In 7th grade, I teach the students how Chuck Norris took down the Roman Empire, so it is good that you are starting early on this curriculum.

 

R.I.P. KOTOR 2003-2008 KILLED BY THOSE GREEDY MONEY-HOARDING ************* AND THEIR *****-*** MMOS

Share this post


Link to post
Share on other sites

Hey Bass mate ive installed the game on windows vista, with the advice at the start of this thread but i can only manage to play the game with sound and movies disabled which sucks any way i can get the sound working?

Share this post


Link to post
Share on other sites

hey I just installed this game on my vista and it is not working. I followed the steps until step 7. I tried dowloading it and it says it is unavaliable. help :(

Share this post


Link to post
Share on other sites

Hi

 

I actually got KOTOR2 to work on Vista without issues but then I finished Peragus and wnet to Telos

 

BLAM it kicks me out

 

 

Ill quickly explain how I fixed my issues

 

To get rid of the annyoing runtime error without much work do this

 

Run it in Windows 2000 comp mode

 

Disable Sound and Movies in the first little Setup screen

 

Start the game

 

Enable Software sound in the Sound options > Advanced

 

Close game

 

Reopen game

 

Activate Sound in little Setup screen

 

 

Everything then works with sound and all

 

Untill I hit Telos

 

 

 

I thought maybe I could just change my save game but the auto save is corrupt so I cant use it.

 

I have changed the dll file

 

Im running a laptop with 945 Intel chipset Vista.

 

If anyone can tell me why it lets me do Peragus and not Telos please do. Cuz atm I feel like a kid in front of a candystore with a ticket to shop for free for 5min and teh shop is closed

Share this post


Link to post
Share on other sites
What about Windows 7? Does it work OK there? Just checking...

 

No. It won't even start.

 

 

Anyone have any ideas?

 

KotOR 1 doesn't work for me on Windows 7 when I just install it and play it, but if I run the setup in compatibility mode and as administrator and do the same thing with running the .exe, it works like a charm.


The sky had never seemed so sky, the world had never seemed so world.

Share this post


Link to post
Share on other sites

Ok, I already have a problem just after step one: I went into Start, My computer, and I right-clicked on the KOTOR II icon... NO THING CALLED "SETUP".

Share this post


Link to post
Share on other sites
Ok, I already have a problem just after step one: I went into Start, My computer, and I right-clicked on the KOTOR II icon... NO THING CALLED "SETUP".

 

You didn't follow the instructions.


62nzp7r.jpg

""Savior, conqueror, hero, villain. You are all things, Revan

Share this post


Link to post
Share on other sites

I spent 3 consecutive evenings attempting to get past the "has stopped working" bug, and none of the fixes worked.

I then I read this post and decided to give it a try even though I had an AMD chipset with an ATI Radeon graphics card (instead of a Intel chipset laptop with on-board video). I was SO shocked and happy when it ended up working!

Turned out I did not have to execute anything/everything with the options "Run as administrator" and "Run in Compatibility Mode." That made installing things much easier!

 

My specs:

OS = Vista Home Basic 32 bit.

Processor = AMD Athlon 64 X2 Dual Core Processor 3600+ 1.90 GHz

Video card = ATI Radeon HD 2600 PRO

Memory (RAM) = 2.00 GB

 

I don't know what is/isn't absolutely necessary, so I'm just listing what method actually worked for me.:

 

1. Installed KOTOR2 using a Normal CD Installation method. (I did not use any 'Run as administrator' or 'Run in Compatibility Mode' options.)

 

2. Installed the game to the local user directory "C:\Users\UserName\Documents\KOTOR2" since Program Files directory hadn't been working for me. (NOTE: This will probably limit the game to a single user being able to play it).

 

3. Downloaded and installed program '3D-Analyze v2.36' - Download Link 1 --- Download Link 2

 

4. Downloaded and installed 1.0b patch. (Again, I did NOT use the options "Run as admin' or "Run in Compatibility Mode")

 

5. Downloaded and installed Optional Media Update Patches. (without "Run as admin' or "Run in Compatibility Mode")

 

6. Rebooted computer.

 

7. Ran "swconfig.exe" from KOTOR2 game directory C:\Users\UserName\Documents\KOTOR2 and set launch options Resolution: 1024x768, Refresh Rate: 85, Texture Pack: High, Enable Hardware Mouse: checked, Disable Sound: checked, all other options: not checked. (Again, did not use run as admin or compatibility options).

 

8. Started program 3D-Analyzer. Under "File Selection" (top left box) selected swkotor2.exe from game directory. Under 'Hardware Limits', checked "emulate HW TnL caps". Hit the "RUN" button - game finally loaded, but without sound.

 

## In order to get SOUND working ##

9. Downloaded zip file containing Mss32.dll and extracted it to the KOTOR2 game directory "C:\Users\UserName\Documents\KOTOR2" (thus replacing the already existing Mss32.dll).

 

10. Started swconfig.exe - unchecked "Disable Sound" option. Used "3D Analyze" to run swkotor2.exe and woohoo!! - GAME WORKED WITH SOUND!!!

 

 

Assuming it wasn't necessary to run the game once without sound, here's brief summary:

1 - Using game CDs, install game without run as admin or compatibility options. (possibly to a local directory such as C:\Users\UserName\Documents\KOTOR2)

2 - Install 1.0b patch normally.

3 - Install (optional) media patches.

4 - Reboot Computer

5 - Place new copy of Mss32.dll into game directory.

6 - Use 3D Analyze program with "emulate HW TnL caps" checked and execute swkotor2.exe in order to start the game.

 

 

Here's a list of download Links for all files/programs I ended up using:

3D Analyze v2.36b - Download Link 1 --- Download Link 2

Version upgrade: 1.0b patch

Optional Media Patches

Archive file containing modified Mss32.dll

 

I hope this will end up helping someone else be able to play this very fun & great game. I know that I exhausted every other fix option without success and was very relieved when I got it to start working.

(Hopefully I won't encounter the other bugs I've read about like the "Telos bug", etc.)

 

Thank you to all other posters contributing their fixes. Without their contribution, I would not have been able to get it working.

 

-Enjoy!

Edited by word304

Share this post


Link to post
Share on other sites

I'm having some major issues getting this to install.

 

I've changed the compatibility and I'm running it as administrator but all I get is an error message.

 

"Windows cannot access the specified drive, path or file. You may not have the appropriate permission to access the item."

 

What does this mean? How can I not have permission?

 

Any help is much appreciated.

Share this post


Link to post
Share on other sites
I'm having some major issues getting this to install.

 

I've changed the compatibility and I'm running it as administrator but all I get is an error message.

 

"Windows cannot access the specified drive, path or file. You may not have the appropriate permission to access the item."

 

What does this mean? How can I not have permission?

 

Any help is much appreciated.

 

Can you clarify what exactly you're having problems installing? Are you installing the game from CD's? Are you talking about one of the patches?

 

To fix your "permission" problem - (assuming you're using Window's Vista):

 

First: make sure that User Account Control (UAC) is actually turned on. You can turn UAC on by going to Control Panel, then double-click User Accounts and yjou'll be able to see where to turn it on. It will require you to reboot your computer everytime you turn it on or off though. Personally, I absolutely hate the UAC option and only turn it on when certain installations require me to. Otherwise I leave it off. Having Windows give a pop-up message asking "Are you sure you want to do this?" for (basically) every little action = super annoying.

 

You can get the correct permission levels through two different methods inside of Vista:

1st - By adding the permission levels directly on your user account - Right click whatever file and/or folder you're dealing with, then select "Properties." Then click on the "Security" tab where it will have a list of "Groups ands Users onames." From there you can click on each individual user account to see it's permission levels. If your user account is missing a permission - simply hit the "Edit" button, and put check mark(s) next to the appropriate permissions you need.

 

2nd - Tell Windows that you will takeover the "ownership" on whatever files and/or folders that you need: Right Click > Properties > Click the button listed as "Advanced" under the Security Tab (which will open yet another new window. To take ownership, click on "Owner" Tab > Hit the "Edit" button (about 1/2 way down the page) and then add your username as the owner.

Share this post


Link to post
Share on other sites
I'm having some major issues getting this to install.

 

I've changed the compatibility and I'm running it as administrator but all I get is an error message.

 

"Windows cannot access the specified drive, path or file. You may not have the appropriate permission to access the item."

 

What does this mean? How can I not have permission?

 

Any help is much appreciated.

 

Can you clarify what exactly you're having problems installing? Are you installing the game from CD's? Are you talking about one of the patches?

 

To fix your "permission" problem - (assuming you're using Window's Vista):

 

First: make sure that User Account Control (UAC) is actually turned on. You can turn UAC on by going to Control Panel, then double-click User Accounts and yjou'll be able to see where to turn it on. It will require you to reboot your computer everytime you turn it on or off though. Personally, I absolutely hate the UAC option and only turn it on when certain installations require me to. Otherwise I leave it off. Having Windows give a pop-up message asking "Are you sure you want to do this?" for (basically) every little action = super annoying.

 

You can get the correct permission levels through two different methods inside of Vista:

1st - By adding the permission levels directly on your user account - Right click whatever file and/or folder you're dealing with, then select "Properties." Then click on the "Security" tab where it will have a list of "Groups ands Users onames." From there you can click on each individual user account to see it's permission levels. If your user account is missing a permission - simply hit the "Edit" button, and put check mark(s) next to the appropriate permissions you need.

 

2nd - Tell Windows that you will takeover the "ownership" on whatever files and/or folders that you need: Right Click > Properties > Click the button listed as "Advanced" under the Security Tab (which will open yet another new window. To take ownership, click on "Owner" Tab > Hit the "Edit" button (about 1/2 way down the page) and then add your username as the owner.

Share this post


Link to post
Share on other sites

I had the problem of running the game before seeing word304's links. I had the first game already on my computer (which ran very slow since it was downloaded instead of cd- which the 2nd one I now play on cd), so I copied it's mss32 file and used it to replace the sith lord's, and now the game works. I've been to telos, nar shadaa, and am now on iziz.

Share this post


Link to post
Share on other sites

Hi,

 

I'm not able to run Kotor 2 on my machine at all (Vista home 32-bit, GeForce 9600 GT (notebook)). Whenever I start the game I get a "abnormal program termination" message. The problem is in the graphic drivers i believe as the hardware scan shows null. I have tried to install the newest drivers available, then the oldest, tried reinstalling, swapping the mss32.dll file, running in xp or 2000 compatibility mode, even tried installing dx tweaker but it doesn't seem to work properly (and i probably wouldn't know how to configure the thing). Anyone got any ideas what to do to make the game run?

 

Any help would be much appreciated.

Share this post


Link to post
Share on other sites

hey i just re-installed kotor 2 again, but the like you have for the dll seems to be expired, please help, i cant find another file anywhere. does anyone have a line or even a file they can e-mail me?

thanks

Share this post


Link to post
Share on other sites

Hi! I just bought Kotor2, but it won't install (Vista 32 Home, Radeon HD 2600 XT). Keeps crashing on the install. I've tried running it in both 2000 and XP compatibility as per the OP, and everything is set with admin privileges, but no matter how many times I try, it crashes with:

 

Error Code: -5003 : 0x8004ace8

Error Information:

>SetupDLL\SetupDLL.cpp (1001)

PAPP:Star Wars

Share this post


Link to post
Share on other sites

Try renaming "InstallShield" folder in "C:\Program Files\Common Files". Confirm UAC prompt (if you have it enabled).

 

Then retry installing.

Share this post


Link to post
Share on other sites

I'am almost tried everything what I have found, but KOTOR 2 doesn't work in my vista. I'am tried to reinstall, patch it to 1,0b, tried to play without sounds, use it in admit and windows XP etc., download new mss32.dll file... But no...It's just doesn't work.

I sended message to SecuROM and sended analyze but they haven't been respond... ****ING vista xD

 

I bought it today and it cost 30

Edited by Larssoni

Share this post


Link to post
Share on other sites

SecuROM sended that new kotor2.exe to me. I copied it to c:/program files/lucasarts/kotor2 and tried to open game from it. Guess what? It doesn't work!!! **** I hate vista...

Any other advices?

Edited by Larssoni

Share this post


Link to post
Share on other sites
the link to the new mss32 file took me to the site, but the file wasnt avaliable for download.

 

edit- it was an error page

 

mine says the same thing, but i dont have kotor 1 installed on my comp and my comp wont let me install it. where can i go to get the mss32.dll?

Share this post


Link to post
Share on other sites

I have an Nvidia card, and was crashing at the very first login. I replaced the DLL file as instructed, taking it from KOTOR I. Then, I was still having problems. So, when the option came up, I chose "Disable Sound". The game started. But it had no sound, and that was annoying. So, I restarted the game, and this time, I chose "Force Software Sound". Game runs perfectly now. Hope this might help others.

Share this post


Link to post
Share on other sites

I'm have trouble with my KOTOR2 game.

It keeps freezing at the first loading screen and the first movie.

I try disabling the movies and sound, setting all the graphic on low.

I've even installed a new graphic driver and the stupid game still work.

I've uninstalled and installed this game 6 or 7 time and IM ABOUT TO BRAKE IT!!!! :sorcerer:

PLEASE HELP!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...