Jump to content

Why does Kotor2 only start in widescreen resolutions?

Recommended Posts

Ok, I seem to have a rather strange problem. It seems I can only play the game in widescreen resolutions, but since I have 4:3 monitor, I'd like to play it in standard 4:3 resolutions instead. The resolution area in the "configuration utility" is blank and I can't select it. And the only refreshrate I can select is 60. Here's a screenshot of it.


The in-game resolution selection box is also blank i.e. there are no resolutions to select from.

All the drivers are up to date. Here's the swinfo.txt: http://hot.ee/aow/swinfo.txt


When I played KOTOR1, The "configuration utility" window was exactly the same, as was the in-game resolution selection box, but in KOTOR1 I changed the resolution/refreshrate from the ini file and it worked perfectly. But for some reason it doesn't work for KOTOR2. If I insert lets say 1600x1200, the game starts in 1400x1050, and if I insert 1024x768, then the game starts in 800x480. :(


Any help would be highly appreciated! >_<

Edited by hereitgoesagain
Link to comment
Share on other sites

How's your video drivers? If that's not it, maybe it's caused by the Catalyst graphics suite forcing that aspect.


Nope, the drivers are good. All other games run fine, including Kotor1. I also tried reinstalling the game and running the unpatched game, but the problem still occurs.



If I insert the same resolution/refreshrate as I do for Kotor1 (1024x768 @ 150Hz), then the game runs like this:




It's in 848x480 and part of the screen is just cut off for some reason....



And if I try running it in 1600x1200, it goes like this:





However while running in 1600x1200 and with the FullScreen=0 instead of FullScreen=1, it still is in fullscreen, but runs at 1400x1050 in a small box (without using up all of the screen:








Has anyone ever had this weird problem before? -_-

Edited by hereitgoesagain
Link to comment
Share on other sites

w00t, problem solved!


You were right, actually! I had used a program called RefreshForce a long time ago to force the refresh rates of certain resolutions, so I ran it again and disabled all the forced refresh rates. After I did that, the in-game resolution selection box was no longer blank, however the highest refresh rates I could select was only 85Hz, so instead of RefreshForce I used ATI Tray Tools for forcing the refresh rate to 150Hz and it worked perfectly! Both the resolution and the refresh rate are correct now.


I hope this will be of some help to someone, should they come across the same problem. :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...