Jump to content

KOTOR 2 & Catalyst 5.4 - BAD!!!


Recommended Posts

Well here we go again on another merry-go-round of bugged games-video driver update route!

 

This time it's the new Cat 5.4 - Which is stated to address the slowdowns in KOTOR - Dantooine.......... .

 

I played KOTOR 2 again for the third time and BAM!!!!! slow-mo world on KOTOR II Dantooine - and it reoccurs until I installed the older OpenGL from CAT 4.11 and used the DisableVertexBuffers command.

 

The gamma is still broken too .......... everytime a level transition and the game graphics engine is reset .......... the gamma goes to very dark and it got to the point where sliding the gamma / brightness slider backwards actually makes the game brighter!!!!!!!!!!!!!!!!! :)

 

What a piece of bad, buggy games - which unfortunately is the trend for PC nowadays - overpriced expensive hardware that costs two arms and legs and still don't work right!!!!!!!!

Link to comment
Share on other sites

Yeap thanks for the comments people......... ;)

 

I do know the fix is only for KOTOR 1 maybe it's wishful thinking but since both KOTORs are using the same graphics engine - maybe fixing KOTOR 1 will fix KOTOR 2???!!!

 

But yeah if not then at least I did not expect Cat 5.4 to break KOTOR 2 by massive slowdowns in Dantooine!

 

Am now having to revert to CAt 4.11 OGL to remedy the situation..........

 

But yeah hopefully Cat 5.4 is good for other games besides KOTOR o:)

Link to comment
Share on other sites

I do know the fix is only for KOTOR 1 maybe it's wishful thinking but since both KOTORs are using the same graphics engine - maybe fixing KOTOR 1 will fix KOTOR 2???!!!

 

But yeah if not then at least I did not expect Cat 5.4 to break KOTOR 2 by massive slowdowns in Dantooine!

 

Am now having to revert to CAt 4.11 OGL to remedy the situation..........

 

But yeah hopefully Cat 5.4 is good for other games besides KOTOR ;)

 

Kotor 1 runs like a slideshow on Dantooine with 5.4 too, the release notes are total crap. Maybe ATI had Lucasarts test it for them...

Link to comment
Share on other sites

The gamma is still broken too .......... everytime a level transition and the game graphics engine is reset .......... the gamma goes to very dark and it got to the point where sliding the gamma / brightness slider backwards actually makes the game brighter!!!!!!!!!!!!!!!!! :)

Blame ATi. They've had broken gamma in their OpenGL drivers for a VERY long time.

 

http://www.nvnews.net/vbulletin/showthread...newpost&t=48841

 

http://www.rage3d.com/board/showthread.php?t=33811384

 

6800GT runs this game flawlessly for me.

Link to comment
Share on other sites

The gamma is still broken too .......... everytime a level transition and the game graphics engine is reset .......... the gamma goes to very dark and it got to the point where sliding the gamma / brightness slider backwards actually makes the game brighter!!!!!!!!!!!!!!!!! :)

Blame ATi. They've had broken gamma in their OpenGL drivers for a VERY long time.

 

http://www.nvnews.net/vbulletin/showthread...newpost&t=48841

 

http://www.rage3d.com/board/showthread.php?t=33811384

 

6800GT runs this game flawlessly for me.

 

Please stop it with the flame war.

 

I had endless bugs with Nvidia and i don't get them anymore.

 

the only time i get problems is when the sodding developer of the game doesn't code it properly to run right with ATI.

 

It is the devs fault NOT ATI or Nvidia.

Link to comment
Share on other sites

Please stop it with the flame war.

 

I had endless bugs with Nvidia and i don't get them anymore.

 

the only time i get problems is when the sodding developer of the game doesn't code it properly to run right with ATI.

 

It is the devs fault NOT ATI or Nvidia.

Ooops. Sorry. I didn't intend a war (probably should have left my 6800 out of it. Again, I am sorry. A flame wasn't the intent, though it was easily taken as such.

 

I did notice that you actually agree to some extent, however, as the quote below illustrates, in reference to a different bug.

But If ATI doesn't get off its' ass and fix the glow problem in their drivers, i will be forced to stop using the 4.3 dll file that fixes it since the X800 cards aren't support in the 4.3 drivers

 

 

Gamma issues have been documented over and over and have been around forever with ATi. That is the only thing I really wanted to adress.

 

Both companies have many bugs left to squish. I just have yet to see any with my card, and am very greatfull.

 

I came up from a wonderfull 9800Pro, which, aside from having a defective memory chip, was a great card. Doom 3 exposed the defective chip, as it fills the whole frame buffer. I enjoyed it till then.

Link to comment
Share on other sites

Yeap - no worries everyone this is not a flame-war regarding ATI or Nvidia as I'm sure each card has their own merits....... .

 

Ah well, looks like I'll have to hunt down an old Geforce 4 or FX card to run on my other Athlon XP machine so I can play KOTOR with the glows etc ........... I do love the games but the bugs just bother me :thumbsup:

 

I had run KOTOR 1 on a old GF4 Ti4200 and the glows are there - and totally missing on the ATI X800Pro - while the GF4 may not have the horsepower it does have better Nvidia driver support it seems for OpenGL..........

Link to comment
Share on other sites

I finally got to testing Cats 5.4 with Kotor 2 and am pleased to say they DID fix the Dantooine lag. I removed the Disable Vertex Buffer Objects line and don't experience any lag.

 

This was tested on Cats 5.4 CCC, so perhaps it only works on the CCC.

Link to comment
Share on other sites

MaglorD, what difference would CCC make ..... I thought it was only a Control Center, therefore it should not affect the operation of the driver?

 

Also with you Cat 5.4 do you get glow effect back?

 

On a separate post, I mentioned using my old original Gecube X800 Video driver which is Cat 4.4 and I got glow effects back on KOTOR 2!

Link to comment
Share on other sites

MaglorD, what difference would CCC make ..... I thought it was only a Control Center, therefore it should not affect the operation of the driver?

 

Also with you Cat 5.4 do you get glow effect back?

 

On a separate post, I mentioned using my old original Gecube X800 Video driver which is Cat 4.4 and I got glow effects back on KOTOR 2!

 

CCC does make a difference. For instance I don't get graphic glitches at 1280x960 using the CCC but I do with the old control panel. Not sure why but that's what I observed.

 

As for the glow effect, I could never see a big difference. If 4.4 gives you the effects you like, you might want to use the 4.4 ATI OGL file.

Link to comment
Share on other sites

The CCC is pure bloatware. When it was first released I tried it once and was disgusted after I realized that the bloody thing eats over 30 MB RAM. ATI would be wise to drop CCC as it is broken by design and I hope it's not true that the CCC benefits from more bugfixes than the more efficient control panel.

 

I have been been using my Radeon 9700Pro for years now, but recent developments (like Shader 3.0) and apparently better drivers might convince me to switch to nVidia if I upgrade to a newer PC.

 

By the way, what is the glow effect everyone speaks of ?

Link to comment
Share on other sites

The CCC is pure bloatware. When it was first released I tried it once and was disgusted after I realized that the bloody thing eats over 30 MB RAM. ATI would be wise to drop CCC as it is broken by design and I hope it's not true that the CCC benefits from more bugfixes than the more efficient control panel.

 

I have been been using my Radeon 9700Pro for years now, but recent developments (like Shader 3.0) and apparently better drivers might convince me to switch to nVidia if I upgrade to a newer PC.

 

By the way, what is the glow effect everyone speaks of ?

 

While I have no love for the CCC, it looks like ATI doesn't leave us with much of a choice. Most of their development effort is centered on the CCC, while the old control panel withers away.

Link to comment
Share on other sites

up until yesterday I had a 9600xt and I experienced major bugs until I added disalbe vertex buffer objects and never experienced a problem again so I was able to update to the latest drivers but. I never tried taking the command away but I think with 5.3 and 5.4 the bugs went away entirely. now I have a 6600gt though and the glow effect is back and I have no bugs whatsoever. :D

Link to comment
Share on other sites

The gamma is still broken too .......... everytime a level transition and the game graphics engine is reset .......... the gamma goes to very dark and it got to the point where sliding the gamma / brightness slider backwards actually makes the game brighter!!!!!!!!!!!!!!!!! :thumbsup:

Blame ATi. They've had broken gamma in their OpenGL drivers for a VERY long time.

 

http://www.nvnews.net/vbulletin/showthread...newpost&t=48841

 

http://www.rage3d.com/board/showthread.php?t=33811384

 

6800GT runs this game flawlessly for me.

 

Please stop it with the flame war.

 

I had endless bugs with Nvidia and i don't get them anymore.

 

the only time i get problems is when the sodding developer of the game doesn't code it properly to run right with ATI.

 

It is the devs fault NOT ATI or Nvidia.

 

 

i develop with OpenGL myself and Ati always manages to screw up their drivers.

it's not my code because even John Carmacks Doom3 code gets crippled by Ati's drivers from time to time..

Link to comment
Share on other sites

For me Dantoonie is impossible to play... but is incredible... i had the same problem... but my system... it say me that is impossible that someone create a game with this problem when it is :

 

amd 64bit 3500Mhz

2GB ram Dual channel-Corsair Extreme performance low latency 2224

ati x800XT Platinum Edition ovk-160-590Mhz 256 MB ram

 

is impossible... incredible

 

Tell me please just 1 thing, We must buy a graphic card for each game that we want play? a different card for each productors? tell me because i'm realy angry that after 3500$ a game of 60$ have this problem on that configuration!

Let's move! release a stupid fix for this problem...(PLEASE!!!!)

 

thank you very much for your attention. And if in a future arrive the third ... oh.. i think that i will buy sincerely Pac-Man... maybe it can WORK corectly on my fk computer.

Link to comment
Share on other sites

Just so you guys know, you have added the line "Disable Vertex Buffer Objects=1" (without quotes) under [Graphics Options] in your kotor2.ini file, right? I did this and bam, no more slowdowns. This also works for the original Kotor, and made a huge difference in the way it played. Just figured I'd throw this at you guys, since I am running with a ATI Radeon X800 Plat Edition, and even I encountered the slowdown until I did this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...