Jump to content

Dantooine... framerate chug chug... semi fixed...


Recommended Posts

AMD XP 2400+

512 MB DDR Ram

Gigabyte Mobo

Radoen 9700 Pro (Cat 5.3)

All latest drivers yadda yadda

 

Anyone else getting huge framerate problems on Dantooine.. seems to be the only place I get terrible framerates.

 

I figured out a small fix... Go into video settings and just check or uncheck various options. Then apply and go back into game.. can usually go for another minute before having to go back in (after it starts to chug again) and then checking anything that isn't checked and unchecking anything that is. Doesn't have anything to do with any effects being just enabled... Wierd bug...

 

It's strange but even with everything disabled or low I can get the framerate issue. So I go in then enable everything then it works fine... for about a minute, then when it starts to chug again I just go back into video options and disable everything and it works fine again for about another minute (rinse, repeat!). Framerate issue occurs much more frequently on the landing pad by the ship. No issues when indoors.

 

What a stupid problem...

Link to comment
Share on other sites

Actually I fixed it using the fix found in various threads, so I cannot take credit for this. You simply use the ATIopenGL DLL from catalyst 4.11.

 

Here are the steps of installing the 4.11 openGL driver only for use with KOTOR2 (these assume you're using Win XP):

 

Ok, so download the Cat 4.11 drivers from ATI's site.

 

Now you have to get access to the files, so go to install them, but after all the files are expanded in C:\ATI\SUPPORT\patch-dir\ , or whatever directory you put them, just quit the installation, you do not need to install 4.11 on your system, you just need access to the files.

 

Now go into command line. (Start->Run... Type "cmd", w/o quotes). Note: this part MUST be done in the command line.

 

Go to the newly created directory (cd C:\ATI\SUPPORT\patch-dir\, or whatever directory you put them).

 

For reference, the patch-dir on my comp is C:\ATI\SUPPORT\wxp-w2k-8-071-041026a-018719c\

 

Now you have to go to a specific sub-directory, so type "cd 2KXP_INF\B_18893".

 

Now in here you'll find a bunch of files of type *.dl_.

 

In order to use the OpenGL driver, you have to expand atioglxx.dl_. So here you have a couple options to type:

 

A.) "expand atioglxx.dl_ <Directory of KOTOR2>"

 

or

 

B.) "expand atioglxx.dl_ C:\"

 

The directory in that command specifies to where atioglxx.dl_ will be expanded. So you can either expand it directly into the KOTOR2 directory, or put it somewhere else temporarily and use explorer to copy it to the KOTOR2 directory from there. In order to use the 4.11 OpenGL drivers, you must copy it into the KOTOR2 directory.

 

Edit: Sorry, forgot a step!!!

Now you have to go into the directory that you placed the file and RENAME it to "atioglxx.dll" it seems that when it's expanded, it's still called "atioglxx.dl_" and will be unusable until you rename it to .dll .

 

So in order to do this, you need to "cd" to the directory that you expanded the file and type the following: "rename atioglxx.dl_ atioglxx.dll". There is no way to do this from windows, you MUST do it from command line.

 

Sorry about that, I forgot it didn't do that for you.

 

I have found that this helps increase performance. I used to have the same problems as you, finding myself switching between having soft shadows and not. But when I did this, it worked like a charm. I hope it works for you!

 

Good luck man.

 

Edit: I also took that Disable Vertex Buffer Objects=1 out of my ini file and it runs as smooth as ever, not that it matters if you have it in there or not after performing this. I actually noticed an improvement from before, albeit minor, but an improvement nonetheless.

Link to comment
Share on other sites

I hope some of the "non-techie" members here realize that is for ATI video cards only.

That's not a cut on people....Some may come in here & read that & say, "Hey! A possible fix!" And screw their machine up even more.

(Dual-Boot)Windows XP Pro (32 - Bit) SP3 & Windows Vista Ultimate (SP 1) 64 Bit | Intel Dual Core 2 Quad 6600 @ 2.4 Ghz | 8 GB Corsair DDR 3 Ram 1600 mhz | GeForce 9600 GT 512 MB PCI Express X 3 SLI enabled | NVidia Forceware Drivers 181.22| EVGA nForce 790I-SLI Ultra MOBO | Thermalake 850 Watt PWR |

Link to comment
Share on other sites

An easy way to unpack the atioglxx.dll is to just open it with Winzip or Winrar and avoid all the command line interface stuff.

 

I have found that ogl driver 4.2 is the best for both KOTOR games. It's a really old version... But it works and both games I can run with 4x AA and 4 AF (ATI card) along with DVBO in the .ini file and get like 50-60 FPS on Dantooine and other graphic intensive areas like Peragus mining tunnels.

Link to comment
Share on other sites

An easy way to unpack the atioglxx.dll is to just open it with Winzip or Winrar and avoid all the command line interface stuff.

 

I have found that ogl driver 4.2 is the best for both KOTOR games. It's a really old version... But it works and both games I can run with 4x AA and 4 AF (ATI card) along with DVBO in the .ini file and get like 50-60 FPS on Dantooine and other graphic intensive areas like Peragus mining tunnels.

 

Just too bad it isn't compatible with their newer cards, like those in the X series.

Link to comment
Share on other sites

Add this

Disable Vertex Buffer Objects=1

under graphic options in the SWKOTOR2 folder  SWKOTOR2 configuration settings.

 

Don't ask how I know because I found it in another thread.  It works though.

 

Yeah, one would hope that this workaround is by now common knowledge...you can skip having to use it if you're on the 4.11 OGL.

Link to comment
Share on other sites

Yes I apologize for the explanation as I assumed too much. I was hoping that by mentioning Catalyst drivers that people would assume they are for Radeon cards only.

 

And yes, adding that line to the ini file will fix the problem. I was just noting that there is another way and I noticed a small performance increase to the Cat 5.3 drivers.

Link to comment
Share on other sites

thanks for the tips. Will give it a shot... well at least the Disable Vertex Buffer Objects=1 addline first to see if it works. Maybe they should just post it on a locked thread at the top... :devil:

 

*EDIT*

 

Thanks for the post to:

 

BUG Game Guide

 

! I had no idea my gamma issues were the result of the game!!! I thought my monitor was going buggered... lol

 

Many users with ATI cards report gamma problems with the game, their desktop becoming very dark or light after exiting the game. Right now there is no apparent fix, or any indicator why some are affected and some aren't.

 

Good to know!

 

**EDIT...AGAIN**

 

Well I must say I've had most of these bugs... I also had one where my game was seemingly corrupted the first time I installed it and had to delete the game directory in order to reinstall. That sucked...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...