Jump to content

Dantooine Low Framerate solution


Recommended Posts

This is obviously a BUG, so for the time being (hopefully the patch will fix this), here's a way of fixing this problem:

I first had the low framerate problem when I arrived to Telos, but it was not that intense at all, although clearly noticeable and annoying. At some point, I accidentally switched to windows' desktop. So, I just clicked on the taskbar marker in order to return to the game.... and much to my surprise, the framerate was fixed. I tried to notice if any effect was gone (pixel shaders, shadows, etc) but they were all still there, in all their glory. Of course, every time a new section at telos was loaded, I had to switch back to the desktop (alt+ctrl+del, or just press the "windows logo" key on the keyboard) close the task manager or the start menu and then return to the game, but hey! at least it solved the framerate problem.

I had no problems at all in the surface of Telos, nor at the hidden jedi base at the pole or on the ebon hawk, so I just played normally. I assumed the low framerate problem would be back at dantooine, since I had read all of these threads talking about the dantooine problem long before I even had the game installed on my computer. So, when all the planets were available, my first destination was dantooine, so I could find out if my little workaround fixed the infamous bug at Dantooine..... and it actually did. When the girl who receives you at the landing point went away, the framerate was OMFG!! so low! so I switched to the desktop, then switched back to the game... and voila! the extreme low framerate was fixed, and the game run smooth as a baby's ass.

So peeps, the trick is just to switch to windows' desktop, and then switch back to the game. Just a workaround until the patch is released, and no FXs lost.

 

PS: I have a radeon9550, 256RAM, 1,8 athlonXP, and have settings at high quality textures, shadows on, grass on, FFAA 2X, anysotropic filter 2X, frame buffer effects on, soft shadows off (I don't like the way it looks when it's on) V-sync off

Link to post
Share on other sites

As I said to other ATI users this is a problem with your card and drivers, not KotOR 2, but may it is. Bioware engines tend to have ATI problems when games using them are initally released. NWN 1 and KotOR 1 had ATI problems when they were first released. Wait for the patch and hope for the best.

Link to post
Share on other sites
As I said to other ATI users this is a problem with your card and drivers, not KotOR 2, but may it is.  Bioware engines tend to have ATI problems when games using them are initally released.  NWN 1 and KotOR 1 had ATI problems when they were first released.  Wait for the patch and hope for the best.

 

It is a known bug *IN* the Odyssey Engine that has to do with Vertex Buffer Objects, hence the "Disable Vertex Buffer Objects=1" paramater specifically for ATI cards and any cards who may have low frame-rate problems as a result.

Link to post
Share on other sites
As I said to other ATI users this is a problem with your card and drivers, not KotOR 2, but may it is.  Bioware engines tend to have ATI problems when games using them are initally released.  NWN 1 and KotOR 1 had ATI problems when they were first released.  Wait for the patch and hope for the best.

 

It is a known bug *IN* the Odyssey Engine that has to do with Vertex Buffer Objects, hence the "Disable Vertex Buffer Objects=1" paramater specifically for ATI cards and any cards who may have low frame-rate problems as a result.

did you read my post at all? I didn't have to disabkle vertex buffer and still found a workaround, very stupid indeed, but it worked, so I still see it as a game's bug. I do believe buying an nvidia card to fix the problem qualifies as a big ass bug.

PS: what is "vertex buffer"?

Link to post
Share on other sites
did you read my post at all? I didn't have to disabkle vertex buffer and still found a workaround, very stupid indeed, but it worked, so I still see it as a game's bug. I do believe buying an nvidia card to fix the problem qualifies as a big ass bug.

PS: what is "vertex buffer"?

 

And your point is?

 

I read your post. You are claiming it is not a bug with the game. That is wrong. End of story.

Link to post
Share on other sites
Actually I addressed to Hades  :thumbsup: and am saying it is a bug caused BY THE GAME.

Anyway, what does disabling vertex buffer objects do?

 

Oh, sorry. I apologize.

 

Vertex Buffer Objects is (in layman's terms) is basically an extention in OpenGL programming that is supposed to allow for certain things to be cached in the video memory of a graphics card in large "chunks" of data and therefore, help render things faster.

 

KOTOR's problem is that somewhere along the way... Either in the core OpenGL code itself or the extention of the VBO it doesn't cache it properly and or doesn't do it as efficiently as it should and sends smaller bits of info. instead of bigger "chunks" that help speed up rendering. This actually might be an ATI specific problem due to their architecutre... But I've read that is in fact an error IN the Odyssey engine that only ATI cards use if that makes sense?

 

I'm not a programmer, but this is the gyst of it from my limited understanding. I am sure more tech savy people on this board can do a better job if I completely buttchured what I am trying to get across.

Link to post
Share on other sites
Vertex Buffer Objects is (in layman's terms) is basically an extention in OpenGL programming that is supposed to allow for certain things to be cached in the video memory of a graphics card in large "chunks" of data and therefore, help render things faster.

 

KOTOR's problem is that somewhere along the way... Either in the core OpenGL code itself or the extention of the VBO it doesn't cache it properly and or doesn't do it as efficiently as it should and sends smaller bits of info. instead of bigger "chunks" that help speed  up rendering. This actually might be an ATI specific problem due to their architecutre... But I've read that is in fact an error IN the Odyssey engine that only ATI cards use if that makes sense?

 

I'm not a programmer, but this is the gyst of it from my limited understanding. I am sure more tech savy people on this board can do a better job if I completely buttchured what I am trying to get across.

So, if I disable it from the ini file, it doesn't mean the pixel shader effects will be turned off?

Quasar, that's actually an easier way to solve it, and I found out about it a few hours after I post this thread. Cool Monkey island 2 avatar BTW :D

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...