Jump to content


Recommended Posts

I didn't had another other problems with my others games until I installed new drivers for my card. Strange.

Could be a bad install of your video drivers. If you do as I said above and it still won't work right, do it again, but this time install the drivers that were working for your comp before.


A newer card would be a good idea if you can spare the money though.

Link to comment
Share on other sites

I actually recommend a Radeon 9600-based card instead, if you're looking for a cost-effective ATI card.


Thay're almost the same, but the 9600 based cards are slightly faster. And both are older cards so you should be able to get them both for near the same price.

Link to comment
Share on other sites

I've encountered just two things the whole game, just wanted to mention them:


1. Force Sight doesn't seem to work with my Main Character and with Visas (even in 1st person mode). It might have troubles with my video card (GeForce 4 MX, drivers all up to date).


2. If I have a cyan color crystal in my equipped lightsaber and enter a new area, the blade is always activated at full length after loading oO

Link to comment
Share on other sites

I've had the same problem on dantooine with the planet becomming lag city with clipping issues like goint through wall as well. It does the same thing on my desktop as well


IbuyPower w/

AMD 64 3400+ at 2.2Ghz

1gig DDR-400

ATI radeon 9700por w/ 128mb ram

Omega driver ver



ADM athalon xp 2ghz

768mb-ddr 3200

ATI Radeon 9800XT a/ 256mb ram on latest Catalist Drivers





Here are some specific bugs ive found


1) during cutscenes atton seems to always have really bad graphical glitches.Its like his body has a pole stickin out of him,doesnt affect gameplay but its just wierd looking,sometimes he will also disappear but you can hear him talking.


2)Characters will walk through doors in cutscenes but they wont actually go all the way through until you walk through the door.


3) Dantooine will all of the sudden become lag city. After leaving the ebon hawk all of the sudden the character will run in circles,not move,not respond to movement.Even after rebooting and restarting the game it still happens in the same exact spot.This one is a gameplay killer as i can not advance beyond this point now

Going to try another planet in the meantime.


4) A few issues of characters saying somethign different then what is written in cutscene.


Link to comment
Share on other sites

If you are having the EXTREME lag when out side on the planet dantoone just do this.

every time you go out side (as in out doors) just go hit esc, go the the graphic options, and change any setting. ANY SETTING. I use the shadow setting and this will correct the problem. The only catch is that you have to do this EVERY tiime you go outside.

Link to comment
Share on other sites

FreakManUltra, there is a much better fix for this, one that has been posted many times.


Taken from my KOTOR 2 Issues Guide:


On Dantooine or in smoky areas, the game can slow to a crawl. This can be fixed by adding the line


Disable Vertex Buffer Objects=1


Under the [Graphics Options] section in the swkotor2.ini file. This restores performance to normal levels and once again makes Dantooine playable.

Link to comment
Share on other sites

Dont know if this was mentioned in this thread but it was mentioned elsewhere. So far the only bug I've had is if I'm playing for a while, conversations seem to go by so fast that I dont even hear them. They'll play if I reload, but that's annoying. For example, when first getting onto the Ebon Hawk. I get "do you wish to board the ebon hawk"", then all of a sudden I'm shooting sith troopers and then atton, kreia, t3, and i are on the bridge of the Ebon Hawk

Link to comment
Share on other sites

I wanted to mention a bug no one seemed to have. When I turn up the brightness in the game and close it out it is fine, but if for some reason the game minimizes to the desktop, or if I turn up the volume up on my laptop, it goes back to being dark and does not seem to remember my brightness setting, but when I go to change the setting is not changed, but the game seems to not recognize the setting. I do have the latest drivers, got the omega drivers to fix the major problems I had just like most people, and I also made the graphic changes my getting into the KOTOR2 file that was posted here, but even still I had this problem even before all these changes.

Here are my specs:

I am running this game on a acer aspire laptop, 1.50 with 512 of RAM. Got an ATI M 9700 and running this on windows XP professional.

Link to comment
Share on other sites

Posting all the things I've put on the Lucas Arts Tech Forums in the past week:



Ya, that X-Ray problem I had that before. Especially around the Telos docking area as well, though even before I left the planet. I had to reboot to fix it.


Here are some screenshots of where I was under the Jekk Jekk Tar when not only the walls disappeared, but my character didn't feel quite...whole.








Here's some more that I took just now in the Cantina on Onderon:




http://www.cczclan.com/files/Justtogetahead7.jpg (if you thought I had it bad this is Canderou..I mean Mandalor, doing his invisible suit like the Parageus spacesuit impression - you can just make out his shadow)





Also notice that people in the background got a bit sick, really greenish in some of these.


Oh and that Exchange Quarren who ran the Refugee Sector, I agree completely, I just posted something over on Obisdon about that as well, I think it was the same guy too, it matches perfectly. I think I mentioned that above as well, not sure though.


So you know, I haven't read all of your posts here completely since I'm not done the game, but I'll check them out as I get to those points.




New one as well, also dialog skipping. I'd just finished giving my first Open Visa (I have one more) to the Women and Children on Onderon, and was looking forward to my reward - namely her thanks and some praise from the Handmaiden. Well, the mother's thanks got cut off before it could finish and then the Handmaiden started to say it was Noble what I had done, then she got cut off as well and I think one more bit of dialog jumped on screen but was gone before I could see it.


Darn. Not satisfying at all.





Total Posts: 24

Member Since: 02/05 Date Posted: Feb 20, 2005 07:09 PM



EDITED BY pjpeter2: Feb 20, 2005 07:34 PM


KOTOR was a masterpeice, they even gave us more great stuff with the PC release, remember Yavin? KOTOR 2 though...anything knew other than even more bugs?


I'm glad though that in 2 you don't need all your characters to be next to you to go to a new Area, because if we did I'd be screwed : ). Mandalore heard that the Bartender wouldn't serve me so he decided to jump behind the counter and give me another round.





Then I got impatient and decided to join him...





Then there is this, this hasn't happened before in my KOTOR/KOTOR II experience - I've been cloned!




Otherwise just minor things like ppl thinking I'm a Swoop Racer (and complementing me on it) even though I never raced and ppl looking for Captain Rieken when he's just around the corner. I think the Neophyte Armor was not supposed to be upgradable - its way to powerful, but I like it - No other Force Compatable clothing has even come close to it in the game so far : ).


Also, if you switch between all your characters and update their attacks, it will start to forget what you programmed them to do and start attacking, even if you told it to do something else better, such as a Force Push, for instance.



Couple more bugs, in the Freeda Nadd Tomb almost all the dialog is way too long, and all of it is English that I have seen. Sits around 5 or 6 seconds at least after the person is done talking before it flips and nothing is going on.


Also, though she didn't say it out load, while Mira was telling me not to go near the Dark Side Energy it said in the subtitles "I'm not a Jedi but even I can sense it" - Well hello, of course she's a Jedi. I've got my own little academy here! Forget Dantoonie and Planet Maraluka the guy should come after the Hawk - everyone but (Old) Ben and the Driods are Jedi...




The combat problem is that it automatically when it spots an enemy sets you up for a certain attack. The thing is, it doesn't let you see the attack - you have to select an attack before the menu comes up at the bottom fo the screen with your new attack as the first one on the menu. But it really isn't - If you cancel that attack you added only then can you see the attack that is really at the top of the stack for you to carry out.


Then you can start adding all the attacks you want to do. This is a simple bug, it looks like an incrementor was off or soemthing and instead of replacing the first attack thats there and displaying it, it shows you the second one and just adds to the list.


Though its simple, its terribly annoying since it affects every single combat we have in the entire game. I really, really hope the new patch fixes this.




Other thing that just happened, about pathing, I was controlling Kreia using Force Screams all over the clearing, and my character actually got stuck on the other side of the square somehow next to one of the sheds near next to where the Basilsek landed. He had perfect health, but he sat there for the entire battle doing Force Heal over and over. Kreia wasn't getting healed, I guess she was too far away (where's the force chain?) but he just sat there the entire time over and over to no affect, even for about 10 seconds after the battle was over and everyone was killed, he still did it 3 more times automatically...just thought that was odd.



One more thing, when I chat with the Royalist Soldiers while heading to get the Palace back (before I take the 1st shield barrier) they say "I knew General Vaklu would not remain allied with the Sith. I'm glad we're free of them." What? That's completely off topic there and only seems to reveal what will happen later...





- At the second shield it says that I need Ben Dur to get through it if I try to bash it with Mandalore. But he wasn't a required character for this mission (Kreia was), so rightly so it works to get through the shield with my Lightsaber (or I'd be stuck). So why does the message popup? Bug.


I don't suppose this is a bug, but the fact that I can Force Confuse the Sith Lord into fighting for me every time I try...boy do I ever feel powerful now : ).


In the Royal Palace there is a Gas Room. I have Breath Control on. Though I don't lose any health points, I keep getting Xed out and therefore can't even move more than a step or two and can't open anything. Quite annoying. What's up with that? It seems they remembered for Breath Control not to take the HP off for getting poisoned, but forgot to turn off the Horror of being posioned...even though I can't be horrified because I really couldn't have been posioned because of the Breath Control...




Also, there is a door in the Royal Palace on Onderon which I can't seem to open or treat in any way as a door. Like the ones at the docks on Nar Shadda. This room is an offshoot of the Dining Room. The next one down the corridoor from the Dining Room has the same problem.


Also, KIPH keeps trying to send Overload signals to the Computer Terminals in the Palace, but they never blow up. Sometimes thats because I disabled his access or stopped the Overload Sequence, other times I let it happen and...nothing happens. It says 'Here's a present for you Jedi' and nothing blows...


Also, Why are Royalist soldiers attacking me? And why are they following General Vaklu? Aren't Vaklu's troops the ones I'm fighting and the Royalists (for the Queen) are my friends? Then why are the ones in the room with Kiph and where they are holding Captain Riekenn, Royalists? They should be Vaklu's soldiers.


Also the Captain in the other room mentioned I could go to the Armory in the next room and take whatever I like. Is that room that has been erased from the Map?




Darn it, I'm screwed! I can't get into the Throne Room and I can't tell Captain Kadran that I got the Security Codes - I had done it already, but I asked him 'Anything you can give me to help me out?' and thats when he told me to go to the non-existant Armory.


I lost the ability to ever tell him I got the codes though, its never an option anymore. Therefore I'm stuck and I can go no further in the game...darn it...



Link to comment
Share on other sites

Like many people mentioned I've had problems with dialouge being skipped over.


Just in case these havent been brought up before.


1. Atton has this grapical...void...in his face. It's on his forhead and it's just s a straight line going from the top of his nose up where you can see the background behind him if the camera anglel is just right.

2. The skills lesson doesnt actaully ad the bonus as Kiera says it should.

3. The most annoying one is that I cant proft from raceing at all. The race starts and even if I avoid all obsticals and make it acroos the finish line with a time good enough to mean I beat a record, I'm told that I cant expect to win if I cant even finish the race. For some reason the game thinks I crashed and didnt finish every time no matter what really happens.

Link to comment
Share on other sites

Hi, My problem is On Telos when completing the mission with B4-D4 where he has to get the info from czerka. When I finish the mission, I talk to the ithorian leader guy like normal, but then when the game puts me back in control of my character, kreia and Atton are gone, no sign of them. Needless to say, this is more than a little annoying after already having put up with the desktop crashing issues, if anyone knows a way to get around this let me know. I doubt this is a hardware issue, but ive attached a copy of my swinfo.txt file it it will help.


Link to comment
Share on other sites

I just purchased KOTOR2 and am unable to consistently play it.


1) The game crashes periodically

2) The saved game files don't always load

3) The autosave games crash the game while loading


I have repeated things over and over and watched areas respawn for no reason after clearing them. KOTOR 1 was a far more stable game. KOTOR 2 is from all appearances not even in beta, it's an alpha stage product. I would very much appreciate a speedy patch.


My system: Intel 3GHz with 1.5 gigs RAM, Radeon 128 MB video card with all the latest drivers.

Link to comment
Share on other sites

I'm experiencing the 1/3 bug, btw I have an ATI graphic card and catalist drivers.

Although there is no dll file like the one mentioned in my system32 folder and eventhough I saw some people saying that they found the file in their cd burner folder, so did I although I deleted it, nothing happends and the bug still occurs, any idea?

Link to comment
Share on other sites

Hi, My problem is On Telos when completing the mission with B4-D4 where he has to get the info from czerka. When I finish the mission, I talk to the ithorian leader guy like normal, but then when the game puts me back in control of my character, kreia and Atton are gone, no sign of them. Needless to say, this is more than a little annoying after already having put up with the desktop crashing issues, if anyone knows a way to get around this let me know. I doubt this is a hardware issue, but ive attached a copy of my swinfo.txt file it it will help.


You just need to add them manually to the party again in partyscreen.

Link to comment
Share on other sites

when u talk to abt improving yourself, she will help u with your skills. asks u what your weakest and strongest skill and come back when u have improved your weakest skill. I did this, and she said that these to skills were improved, but all I got was an increase to my force powers, no increase to my strongest or weakest skill.

Link to comment
Share on other sites

After saving the Queen on Onderon, I can't enter Dantooine, there's only a black screen and the pointer, it doesn't hang, simply the level does not load. All other planets and levels work except for this one. I have completely stuck. Is there a way to work it around?


My specs:

AMD XP 2400+

Abit KD7-G


GeForce FX 5900XT 128MB with the latest driver

Link to comment
Share on other sites

Another problem I had was in Freedon Nadd's tomb, there were two Sith Warriors just standing there doing nothing and they wouldnt talk nor attack.


Also after finishing Nar Shaddaa and the second trip to Onderon to save the queen, I went to Telos to tell Lt Grenn about the new fuel source. The thing is the game wont let met tell him. I approach him and he says "Youre back" and my only options are "nevermind" and asking about bounties.

Link to comment
Share on other sites

on shar naddaa, the little girl, adaana, who is going to be sold to the hutts, is slightly bugged. After I killed her guards, I told her to go home, and then I wien and killed the overseer and his thugs. Then I went to see the girls mother for my reward and she asks if I have freed her daughter yet and my options are no, not yet, and I'm still working on it.

Link to comment
Share on other sites

Had a situation on Peragus after going through the dormitories when, instead of cutting to the scene where you talk to Kreia and recruit her, it jumped instead to the battle scene with HK-50.


I knew something was wrong when, after defeating HK-50, Atton was in my party, but Kreia (who foolishly rushed HK-50 and got herself killed), was not in my party and in fact dead as a doornail.

This is my first play through, but I'm assuming that Kreia shouldn't have died here.


Has anyone else encountered this?

Link to comment
Share on other sites

I have a new bug in addition to the other previously mentioned bugs, like ever standing persona's, swoop races always result in 'You actually have to finish the race to win!', and the occasional T3 dialog twitches... and another hundred or so bugs.


This sucks:


After leaving Onderon with Mandalore to get back to the moon (first time if several), a movie starts leaving the planet, landing on the moon etc. All fine, apart from the switching between desktop and gamescreen when changing scenes. Then an in-game cutscene comes up showing you talking with Mandalore. You talk with him until he says he'll talk more another time. Then cameraview changes, and a guy comes walking in from the bottem in the view. Then.... nothing. The game semi-freezes. All characters keep idle-standing, breathing etc. but nothing happens. The cutscene isn't over, but doesn't end either. The mousecursor is there but nothing can be clicked, and no key works, except ALT-F4.


Tried solving it by starting an old savegame, but the same result. Also tried the savegame on my friend's computer, same thing happens. Also tried different video configurations and whatnot... nothing works. This must be one of the worst bugs yet, as you fully developed a character, and followed a lot of the story, and suddenly.... you're stuck forever due to some bug.


**** that

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...