Jump to content

*** Post your bugs/problems here ***

Recommended Posts

From all that Ive read and heard all these bugs within the game have really crippled gameplay for some. Post any issues you have experieced so that the devs maybe do what they can to fix the issue. Giving game feedback may also make way for a patch over Xbox Live.


Ill start with an issue posted from a gamespot fourm user which seems to be common.


-Screen would go black while comming back from a menu.


-Occasionally the character will run away from the target, including through obsticles and walls before turning around and coming back to the fight.


-Doors either do not open when they are supposed to or a door is left open, but is displayed as closed, you simply have to walk through the image of the door.




Keep em comin.


EDIT :PLEASE POST THE MAIN ISSUE IN AN ABREVIATED DOT POINT FORM AND IN RED. Further explain if necessary in normal colour.

Link to comment
Share on other sites

From what I've heard, they can't patch it over live, but they will most certainly release a next generation disc in feburary with the world wide realease, so I will contribute.


-On Nar Shadda, my screen went black during the T3 mission when he had to go into the warehouse. Cause: T3 was not a playable character at the time. He was never properly rescued from Peragus, the cut scene when you get into the fuel line from the Harbinger Engine Room never played. Confirmed by the fact from an earlier save on nar shadda, the 'rescue T3' quest was still active. Had to restart the game, effectively.


-When I convinced the Handmaiden on the Ebon Hawk to train as a Jedi, Telos Academy loaded and I was trapped there, I had to reload. Cause: Unknown, the only thing I can think of is I had completed all four planets already and was heading to dantoonie to meet the masters; but that is only a theory.

Link to comment
Share on other sites

I already wrote something like this in another post but since this thread is more centralized, I'll mention it again (with some new additions) :


There seem to be several problems with scripts setting/checking for global/local variables that fire when you enter a module:


I was on Dantoine and saved my game just when entering a module and before talking to Vrook and fighting him. I died during the fight and reloaded my game. Vrook never reappeared, even when exiting and re-entering the module and it was really a big turning point in the plot.


Exact same thing happened on Nar Shadaa: I was suppose to meet "Visquis" ( in the "toxic" bar. I was playing as a Dark Side female sentinel. I saved my game just after I enterering in the area where you meet the Wookie if you are DS or Mira if you are LS. I met with the wookie. Until then, everything is fine. However, in the next sequence, I was transported to another module where Atton has to fight alone, he was ill equipeed and died. When I reloaded, the wookie never appeared. I got Mira instead and it was all messed up.


From what I have seen, this also happened to someone else with HK-50 on Peragus. After reloading the game, hk-50 would never attack you. Someone also mentionned a similar problem in the Tomb on Korriban when you enter the tomb with the "visions" and the door at the end would not open. I have also seen similar problems at other places but I don't remember them all (I think I've seen something with t3-m4 on Peragus)


The above problems won't show up if you don't save/die at the wrong place at the wrong time...but when you happen to reload your game at one of those moments, it is really annoying as those affect major sequences in the main plot.


The solution I found is not to die :) or save before entering a module. Once you are in a module, you can also save safely after an event (example, after talking to the Wookie on Nar Shadaa but not before) but this rather annoying and not practical, especially for people who are not familiar with how plot advancement works .


At some places, I got the feeling (I did not verified any of this) that some of the scripts that set some plot globals are fired when you enter some modules and not when the action is perfomed (Vrook case? )


There are also some problems with dialogues. Wrong branches trigger at the wrong time sometimes. As an example, the dialogue with the Salvager who sells lightsaber stuff near the ruins of the Jedi Enclave is all messed up when you go back to her once you are a Jedi. Also, a few places the text doesn't match exactly what is being said.


I hardly understand how these things have never been noticed during testing. Did all those guys played in god mode or what? I get the impression that testing has been rushed out. All the above is really simple to fix (.tlk table editing and a few lines of code here and there) and I really hope Obsidian will fix this for the PC version.

Link to comment
Share on other sites

* Force powers are not giving any defense bonuses. This weakens the Speed series and makes the Aura/Shield/Armor light side powers useless.


* Workbenches do not account for the character using the workbench when breaking down items. They always use the Repair skill of the main character, unlike its behavior for item creation or the behavior for the lab station, which follows the skill of the character using the station.


* Many instances of glitches in characters during cut scenes. In particular, Atton will turn sometimes around or stand when you talk to him on the Ebon Hawk, which is impossible since he starts off sitting down on an unmovable chair. Plus, he's too far away from the console and looks like he's pushing buttons in thin air during conversations. Characters disappear faster than the fade in and fade out, characters shift or teleport positions between scenes, the camera glitches and briefly shows different characters for a split second, and so on...


* Dialogue options are inconsistent and bugged. For instance, the Handmaiden will teach me Battle Precognition the first time I talk to her on the Ebon Hawk, but clearly I'm not sparring with her during the dialog as the dialog indicates, and I likely shouldn't have enough influence with her to be able to reach that option to begin with. Same thing with Visas Marr, she'll teach me her special Force power in the first conversation, while talking about how I've traveled with her -- except I haven't left the Ebon Hawk with her yet.


* Not necessarily a bug, but were all characters intended to have the same To-Hit progression? That's a big change from the lower To-Hit that anyone except a soldier type would have in standard D&D-type rules.


* Where's the feat for unarmed finesse?

Link to comment
Share on other sites

From what I've heard, they can't patch it over live, but they will most certainly release a next generation disc in feburary with the world wide realease, so I will contribute.


This is just a tip: I was over at EBGames yesterday, trying to exchange my disc for one that would fix the bugs (didn't work , but anyway) they offer a deal where you can buy insurance for a year on the game for like $3. So, if you bought your copy at EBGames, it might be a good idea to go over there, insure the game, and then maybe return it if they do release a next-gen disc.

Link to comment
Share on other sites

I've had a couple of bugs.


#1) on Dantooine lower levels, while engaging some foes in combat, the game sorta went into slow motion (I think it was because I accidentally engaged stealth mode at the instant I spotted the enemies). I dont mean a framerate issue either. The game would literally STOP cold, and when you hit the D-pad, it would move very very very slowly. Very odd. I had to stop the game, save it, then load it back for the problem to be fixed.


#2) At the entrance of Freedan Nadd's tomb when the Mandalorian with you begins to talk and tell you he will wait on you, I got a pop up screen on my screen that said something to the effect of "Dialogue tree broken, PLEASE CONTACT A DEVELOPER)." Anyone seen something like this? It has only happened that one time, and did not happen on my first playthrough. I was sorta surprised they actually had a screen that said to "contact a Developer."


The rest of the bugs have been the usuals -- framerate issues, PC character running away out of control etc...

Link to comment
Share on other sites

Ok, so spent lots of time trying to get my consular/Master to beat HM so I could make her a jedi. Not easy when you really don't have much in the way of combat skills.


So, i beat her, Krea says "betayal" and transports me to the Telos academy. Only the place is totally empty. Atris door stays locked, there's no one else around, and I can't board the Hawk, or change my party.


I first tried this on Dxun i think. Then we went to Nar Shadda so i could try and turn Mira.


I;m at the point where I have to go to Dantooine to meet the enclave. Don't know if that has anything to do with it or not, but krea won't talk to me about anything else other than "we must go to dantooine now".


I'll try it from there when i get home from work. I also started a new Guardian character specically so i could do melee, if it doesn't work for that one, I'm going to seriously condider downloading a game for the first time in my life so i can actualy play what i payed for.


Seriously, was this thing even play tested?

Link to comment
Share on other sites

Something did happen last night on my game that im not even sure was supposed to happen.

On Dxun when the sith attack the Mandalorian camp im fighting the sith and then suddenly im talking to Mandalore and we are off to Onderon. The problem I think I had is that on my LS playthrough I fought all of the sith not just one.

Link to comment
Share on other sites

I ended up with a worthless autosave while on Nar Shaddaa. During the fight with the crew of the Crimson Sun (the ship who's docking pad you're using), my PC was KOed, but the NPCs finished the fight. Before the PC revived, the game autosaved and then loaded into a cutscene. As soon as the cutscene begain, I received the popup saying all my party members were dead and to reload a saved game. Reloading the autosaved game always resulted in the same thing. The save recorded my PCs hp as 0, and after starting the cutscene, the PC was the only party member, resulting in a dead party.

Link to comment
Share on other sites

navarre, download you mean the pc version?


I imagine in due time the xbox groups will fix it somehow. Sadly it's looking like it will take one of those modchips :thumbsup:. Maybe the devs left some way to override assets in the game though.

Link to comment
Share on other sites

navarre, download  you mean the pc version?


I imagine in due time the xbox groups will fix it somehow.  Sadly it's looking like it will take one of those modchips :).  Maybe the devs left some way to override assets in the game though.



Yep, I already payed for the game, and instead got a largely buggy mess instead. This particular glitch may not be gamestopping, but I worked hard, and in a legit manner to beat HM.


Well, I used mines, and lots of them, but I still leveled her correctly, and didn't do something lame like not level her at all until after I had beaten her. Now, I can't make her a jedi.


Plus, all the freezeups and the corrupted saves because of the freezeups.


Considering this is exactly the same engine that was used in the first one, there is absolutley no excue whatsoever for these kinds of bugs. Sure, lucas wanted it out in time for xmas, but if they hadn't, would this thing even see light on Xbox1? given its nature, I imagine it must have had years left of testing before it was ready.

Link to comment
Share on other sites

Anther bug regarding the twilek you can rescue in the base at Telos. It's a pain in the *** . He gets stuck behind every minor obstacle. I tol dhim about 30 times " just keep following me" to end up on a black screen (and no I don't have a modded xbox) . (Why not have an option to tell him "the way is clear you can go out and attach a script that makes him run away and destroys the object instead)

Link to comment
Share on other sites

I have had several 'black screens' occur through the game and areas where I have completed a task and I cannot move on. Thank goodness for saving alot! or I would never have been able to finish the game. (and I do not have a modded xbox)


#1 complaint:

Black screens!!!!


The only way I have found a solution to getting out of it is <b> When you are in black screen</b> GO INTO THE MENU SYSTEM (and it will pop out of black screen) THEN SAVE! --- THEN RE_LOAD that saved game and it seems to be fine.

It is very frustrating and it occured about 8 times through my first time through the game.


#2 Complaint:

'Infinity Story'


While playing as a light side male, there were times when I would be in the end of a particular task (the ending facing my master for one, facing my master in the tomb for another, and 3 other times in the game) where I could not move on... SIMPLY STUCK IN A CONVERSATION LOOP WHERE I AM FORCED TO REMAIN BEHIND LOCKED DOORS AND RESTART THE SAME DARN QUESTION ANSWER WITH THE PERSON I AM WITH) very, very frustrating....


Those issued seemed to be all through the game making the story very hard to stick with.


My own opinion: It seems this game KOTOR#2 was rushed to market because it had a pre-Christmas deadline and the Q/A done on it was not as through as it could have been. In some ways I wish Obsidian would have taken care to really <i>finish</i> this game Before sending it to market.


And I think the good group of Obsidian had a grander plan for the ending with animations <i>with</i> people - instead of what was left in the game.


I do not mean any insult to the story,; it is rich and full of good stuff but the game did not seem as polished as the first KOTOR...


Do the Dev People:


#1 Will there be any patches to fix various issues in the game coming out?

#2 Any additional planets/game storylines planned like KOTOR1?

#3 Will there be a KOTOR3?




Link to comment
Share on other sites

I've already posted my only encounter with game destroying glitchs in this forum, but I might as well chronicle it in this neat little collection. Perhaps we'll get some insight (or at least a passing comment) from the devs using this method. I'll try to make this as spoiler free as possible.


* Whenever I visit Dantooine for the last time (40 hours into the game) I've encountered a reoccuring freeze where the game goes into the cutscene with my charater in the rebuilt Enclave entering the room where he will confront the Jedi Masters. So far, this has only happened with my darkside characters.


* I've also encountered what may possibly be a broken quest. A few other chaps posted messages about this on the Spoiler Forum. Though I can complete the Telos Fuel quest, the game, for some reason will not register the Vogga the Hutt quest complete. The journal entry for this quest states that I can use Vogga's obsession with Goto (learned from the thugs in the cantina) to gain an audience with the Hutt. Obviously I have already gained an audience with Vogga, having completed the Telos Fuel quest, so what gives? Broken quest?

Link to comment
Share on other sites

* I've also encountered what may possibly be a broken quest.  A few other chaps posted messages about this on the Spoiler Forum.  Though I can complete the Telos Fuel quest, the game, for some reason will not register the Vogga the Hutt quest complete.  The journal entry for this quest states that I can use Vogga's obsession with Goto (learned from the thugs in the cantina) to gain an audience with the Hutt.  Obviously I have already gained an audience with Vogga, having completed the Telos Fuel quest, so what gives?  Broken quest?

Had exactly the same thing happen to me.

Link to comment
Share on other sites

* Cutscenes consistently show another scene before loading the fade-in or fade-out. When loading cutscenes, it needs to stay black completely before the scene is loaded.


* Any time you get too close to someone and start a dialog, the camera ends up clipping into one of the characters, so you end up seeing half a face or some other glitch.


* Cutscenes need to place characters before they start. Sometimes you can get characters still moving or facing in a different direction than the devs seemed to want, which screws up the camera angles and causes animations to snap, where the character does the scripted animation and then snaps back into their previous position between animations.


* For the two escaped fugitives on Telos, I told Grenn that I'd seen them, but he needed harder evidence than my word. However, they never showed up on the planet surface like I know they're supposed to, before you get to Atris, and Grenn never has anything else to say about them.


* I've also had the mentioned problem where the Twi'lek in the Czerka surface base won't follow my party past some obstacles, so I couldn't save him because of the pathing.


* The Ithorian you can save from the Exchange base didn't give me any Light Side points.


* I've had one save game with Mira where she was not wearing the environment suit when she visits Visquis, which makes the game totally confusing when everyone is surprised it's Mira instead of my Jedi.


* For the quest involving a dancing girl for Vogga, if you wait until after picking Mira up to do it, then have both her and the Handmaiden in your party and ask Mira to be the dance girl, she'll agree, but when you get to Vogga's lair, the Handmaiden will step forward instead. When the cutscene switches to the part where Mira is supposed to be dancing, no one is there.

Link to comment
Share on other sites

I just got the game on Christmas, and I've had a few problems. One problem I've had is that the game freezes sometimes at the Press Start screen. Also, while playing the game I have had some freeze-ups and slow downs (while fighting, moving, talking, or in the pause menu). Also, I have started to notice my Xbox making odd sounds...like a whirring sound of some sort. My Xbox happens to be one of the first models released, so perhaps it's beginning to get old. I also finally picked up an Xbox DVD Remote, and I don't know if that might drag the system down a bit. And no, my Xbox is not a modded one. One last thing, I also rented the game before recieving it, and the rental copy worked just fine. I'm not sure if I should exchange it, or if there is a possible solution to sort of...give the system a boost. Any hints or comments would be appreciated.

Link to comment
Share on other sites

* I've also had the game freeze on me a couple of times while trying to access the shopping screen for Kodin, the droid parts merchant on Nar Shadaa.


* The Twin Suns drop their swords every time after being defeated, so since you fight them twice, you can get two copies of each of their swords (four swords total) if you go back to the cantina on Nar Shadaa.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...