Jump to content

Cant upgrade my lion greatsword

Recommended Posts

I cant upgrade my antlion greatsword and I don't know why. It only requires 10 spicy globs to get from level 6 to level 7 and I have 12 on me to be extra sure I have enough. It makes the sound of it being upgraded, but it doesn't actually upgrade. The sent video was before I had 12, I've tried to upgrade it with 12 in my inventory and it still doesn't upgrade.

Link to comment
Share on other sites

  • 4 weeks later...
Posted (edited)

I’m having the same issue. Attempting to upgrade both salt and spicy versions of the antlion greatsword from level 6 to level 7. It makes the upgrading sound but then nothing happens. I’ve tried with resources in my inventory and in storage  containers. Nothing works. 

Edited by dpaps17
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...