Jump to content

Rizzo Secret Labs - Crash to desktop. Any workaround?

Recommended Posts

Hi folks and space travelers,

I'm facing a pretty annoying bug in Cascadia. As soon as I take the elevator for Rizzo Screts Lab, the game crash to desktop during the loading screen. I tried various thing: Changing companion, dismissing them and entering alone, reloading the zone by visiting another planet first, progressing the main story a bit further before accessing it, without any luck so far. Still the same crash. My GPU drivers are up-to-date and changing graphical setting doesn't change jack either.

There's a few CTD related topic around here, but so far, no solution provided in other thread did the job for me. Would any of you be aware of a fix or a workaround ? There's apparently two quest inside (A science weapon and one to smuggle out Algae-gas) that I'd like to complete.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...