Jump to content

Recommended Posts

When attempting to install The Outer Worlds on either the Microsoft Store or the Xbox (beta) app it doesn't begin to download instead showing a 0x80073cf3 error. I am running the most up-to-date version of windows as an admin and have tried turning off all my anti-virus, installing on a different account but I keep getting the 0x80073cf3 error.


Is anyone else having/had this issue and can help?

Link to comment
Share on other sites

I had a similar error though cant remember if it was the exact same code.  There was not enough space on my hard drive and fixed it by using treesize to delete old files to free up space.  The xbox pc app installation pop up miscalculates free space and shows there being space available that isnt there. 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...