Jump to content

Recommended Posts

After a lengthy period of gathering players' feedback, theorycrafting and balancing, we have come with a Community Patch Mod - a community based collection of tweaks and improvements.


Community Patch consists of the following stand-alone modules:

  • Basic - includes a lot of suggestions from the Deadfire Polishing Poll - a poll made by players for players, in order to pinpoint the possible balance problems and address them. Basic mod - is a conservative patch, it includes only those suggestions that have twice more votes pro than votes against change. (note: in case of suggestion with multiple options - we were aggregating them)
  • Extra - also includes the suggestions from Deadfire Polishing Poll. But only those that didn't make it into Basic package, but still have more votes pro than votes against. Additionally, Extra includes a few fixes for several bug reports that we have found on the official technical forums.
  • Keywords - address the randomness and apparent lack of systematic approach to spell keywords. This mainly affects priest, and to a lesser degree druids, ciphers and wizards.
  • Typos - fixes a wide array of typos found in the English version of the game.
  • Icons -  adds a completely unique set of icons for all passive talents and effects. They were handcrafted with being as suggestive, unique and fitting as possible, in mind.


For more info, you can check the mod page, or original thread on these forums, here.

Edited by MaxQuest
  • Like 13
Link to comment
Share on other sites

  • 3 weeks later...

Hello. I applied this mod, and the icon sets seems broken to me. I turned off all the other mods and placed this mod set as the description; set icon mod to load last / at the bottom of mod list.

How could I solve this problem?



I solved the problem. :) I just did mistake when extracting the file. Sorry for bothering you.

Edited by Hoo
Link to comment
Share on other sites

  • 1 month later...

@MaxQuest, @Boeroer


I has a sad...


Had UC working on mates machine and thought the breaking was down to my machine and GOG vs Steam.


Unfortunately I've found out the fail in the "Add Abilities" section of UC is a direct result of CP-Icons specifically. I can have everything else but it either off or a mix... no change to state.


Full List and no Icons? Add Abilites works

No List and Icons? Borked even on a fresh new game save with zero edits done and no residue from prior mod use


Take Icons out and reload save? Add Abilities works again

Take Modded Save and remove Icons? Add Abilities works again.


Not sure if you'll be able to fix it as I've no idea why it's causing an issue unless there's different names in the bundle for the Icons Override?  Was more so you could stick a Warning on the CP page for users of UC that want to use Add Ability for replay runs or testing builds etc.

Link to comment
Share on other sites

There are no problems when using the original addability command with the Deadfire console. Also the icons were added according the tutorial of BMac (afaik). So maybe it's a fault of Unity Console? It messes around with the game a lot more than the Community Patch. 

Just a guess though. A warning on the mod page would be fair of course. 

Did you try to fix the issue by changing the load order of mods? E.g. load CP as last mod or try UC as last mod?  

Edited by Boeroer

Deadfire Community Patch: Nexus Mods

Link to comment
Share on other sites

9 hours ago, Boeroer said:

Did you try to fix the issue by changing the load order of mods? E.g. load CP as last mod or try UC as last mod?  

Unity Console uses IPA to "cook" a new exe and libs for the game, so it doesn't appear in the mod list due to being Base/System level alterations.


The "break" in Add Ability occurs with it being not only the only active, but the only resident and loaded Mod ( I did a "dummies" level test by shifting everything else out override folder and reloading into the Prologue Cabin.


Icons either active as only mod, or active with any level of mods... Broken Add Ability.

Icons either inactive ( but present in override ) or just not installed in Overrride... Add Ability works fine.


I tried stress testing it and even "breaking" the model rigs etc with GodTint and Godlike Unlocker doesn't break the UC, and Load Order doesn't seem to matter. It's simply when you try and load Icons with Unity Console, something in one of them doesn't like the other ( I'm guessing UC is looking for the old Icon properties ) and the Add Ability borks.


You can work around it by doing a Convert and then setting either Weaponskill or Ability high for one level and removing, but the real killer is if you want to do something like add the Eder Pet Unlock etc for an RP run. As said it was more to see if it was an easy fix since UC seems "lapsed" dev wise, and if not just to let you guys know so you could add a caveat to the testers/hardcore tweakers now I'd tracked it down for my case and been able to reproduce it reliably and exclude other causes.


Personally I'm just living without the second pet and using the workaraound... the new icons are just too nice. 😄

  • Thanks 1
Link to comment
Share on other sites

I'm getting crashes on area change. I doubt this is the cause, but does this need a fix?

Parse read unexpected property 'DisplayName' ('G:/SteamLibrary/steamapps/common/Pillars of Eternity II/PillarsOfEternityII_Data/override/CommunityPatchBasic\design\gamedata\cl.cipher.defensive_mindweb.gamedatabundle' ln 5 col 18).
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

Parse read unexpected property 'Description' ('G:/SteamLibrary/steamapps/common/Pillars of Eternity II/PillarsOfEternityII_Data/override/CommunityPatchBasic\design\gamedata\cl.cipher.defensive_mindweb.gamedatabundle' ln 6 col 18).


Link to comment
Share on other sites

  • 1 year later...
  • 3 months later...

If you PM Max on the Nexus he'll get an email notification and get back to you. I've been in touch with him yesterday to hand over the updated typo component.

"Time is not your enemy. Forever is."

— Fall-From-Grace, Planescape: Torment

"It's the questions we can't answer that teach us the most. They teach us how to think. If you give a man an answer, all he gains is a little fact. But give him a question, and he'll look for his own answers."

— Kvothe, The Wise Man's Fears

My Deadfire mods: Brilliant Mod | Faster Deadfire | Deadfire Unnerfed | Helwalker Rekke | Permanent Per-Rest Bonuses | PoE Items for Deadfire | No Recyled Icons | Soul Charged Nautilus


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...