Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Weird party non-combat speed bug...

bug non-combat speed

  • Please log in to reply
5 replies to this topic

#1
waltc

waltc

    (3) Conjurer

  • Members
  • 103 posts

I am going to attach a crash file here that your software created for this purpose so that you can review it.

 

1) It happened in a saved-game file saved in 4.1.0.0023, after the game was loaded in 4.1.1.0034.

 

2) Description of the save: had just made port in Nantucket(sp?--try not to laugh too hard...I simply cannot recall the exact name of the port... ;)), and had defeated the harbor lord's edict to leave port--by way of my spiritual proxy summoning spirits of the dead to scare them off  (and quite effectively at that.) Saved the game at that point in 4.1.0.0023. Bug manifested when I loaded that game in 4.1.1.0034--game upgraded through the GOG Galaxy update mechanism.

 

3)Description of the bug: after loading saved game as recounted in (1) above, for some reason my entire party was moving at 2x normal speed--instead of normal walking--and when I used the non-combat speed-up option, bizarrely, the entire party was flying everywhere at 4x normal speed--resembled a horde of enraged yellow-jackets swarming!... ;)  All controls functioned--I could toggle non-combat speed-up between 2x and 4x fine--but under no circumstance would movement return to normal walking--which I assume is 1x speed.   Pressed every option button known to the game and then some, all to no avail.  So this is the bug.  See attached crash files.

 

4) I have already overwritten the saved-game file, apologies.  One of those "delete before you think" situations.  (Actually I overwrote it with another save.)

 

5) However, I had other saves from the same version which I loaded, as per (1) above, at almost the same place--and none of them exhibited the same bug at all--so that's the good news, I suppose. All of the subsequent saves and reloads in 4.1.1.xx were free of the bug.

 

6) I have not experienced this bug since. Hopefully your crash files will be of some help!  It looks like a one-off to me, but then there might be something in the code you would care to fix, etc.

 

ALRIGHTY, then...your uploader refuses to let me upload anything, even a .rar file 44kb in size--far, far smaller than one megabyte.   I have used the standard uploader and your flash uploader--to the same end--I am refused uploads on any files, regardless of file extension.

 

'Kay.  I tried.

 

Query: What is the point of providing instructions on bug finding that don't work?  Please advise.  Thanks.

 

 



#2
arkteryx

arkteryx

    (2) Evoker

  • Members
  • 88 posts

This is a known bug, several other posts about it. Hopefully should be fixed soon.


  • waltc likes this

#3
waltc

waltc

    (3) Conjurer

  • Members
  • 103 posts

This is a known bug, several other posts about it. Hopefully should be fixed soon.

 

Thanks!  Still don't know why they don't want my crash file uploaded.  But this info is appreciated!



#4
Abathorn

Abathorn

    (1) Prestidigitator

  • Members
  • 8 posts
  • Pillars of Eternity Backer
  • Kickstarter Backer
  • Deadfire Silver Backer
  • Fig Backer

It's the same with me. With a new game i've created yesterday I am not able to run in a normal speed for my characters.

 

Any idea when it might be fixed?


Edited by Abathorn, 18 February 2019 - 02:02 PM.


#5
waltc

waltc

    (3) Conjurer

  • Members
  • 103 posts

It's the same with me. With a new game i've created yesterday I am not able to run in a normal speed for my characters.

 

Any idea when it might be fixed?

 

The fix that worked for me was:

 

1) Select your main character in the party so that everyone else in the party is de-selected

2) Direct your main character to walk  a few steps--you will see that his walking speed is back to normal

3) Hit the "select all" button in the UI to select everyone--and then walk--should be back to normal for the entire party at that point

 

(If you leave out 2) above--the workaround fails, so do all three steps in that order. Takes all of 3-4 seconds if you're slow...;))



#6
SChin

SChin

    Product Services Manager

  • Developers
  • 902 posts
  • Location:Irvine, CA

Hello everyone!

 

Sorry for that speed issue.  This should be fixed as of the v4.1.2 patch released earlier today.  Please let me know if the issue persists afterwards.

 

In regard to the files from the crash, I would love to have those if you could send them to me at support@obsidian.net along with a link to this thread as a reference.  Unfortunately the forums don't allow very large files.

 

Thanks again for the help and sorry for the inconvenience this has been causing.

 

P.S. I had to laugh at "Nantucket" since i used to live near there :)







Also tagged with one or more of these keywords: bug, non-combat speed

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users