Jump to content
  • 0

NVIDIA Graphics low Frame Rate Update


hillbo

Question

Hi All

 

Just wondering if there is any updates on the frame rate issues with high end NVIDIA cards? Many of us are still getting low FPS drops and there is no stable/reliable fix. 

 

An update/Pactch/Permanent fix would be greatly appreciated :).

 

Kind regards

 

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hello everyone,

 

Sorry this is still an ongoing issue.  We are still waiting on external support to help us see about getting a fix to these issues for certain Nvidia cards.  I am quite curious about this mod that stackedmidges posted but we don't have any machines internally that are having this issue.  if you end up using this mod and have time to let us know how well ti worked for you, we would greatly appreciate this.

 

Thank you everyone and sorry again for the longevity of this issue.

Link to comment
Share on other sites

  • 0

Just want to chime in to say that this is ruining my experience of the game, I get stutters every 10 seconds that drops the fps down all from 10-20 fps every stutter. Graphics card:  GTX 1070 Ti.
I've tried the Special K-mod which gave me some frames (the setting that halves the number CPU cores used helped me and many others) but it didn't solve the _consistent_ stutter issues. Obsidian should look into what the mod is doing + maybe get on with getting the external support.. we're 1+ year in with these issues.

Link to comment
Share on other sites

  • 0

Hello everyone,

 

Sorry this is still an ongoing issue.  We are still waiting on external support to help us see about getting a fix to these issues for certain Nvidia cards.  I am quite curious about this mod that stackedmidges posted but we don't have any machines internally that are having this issue.  if you end up using this mod and have time to let us know how well ti worked for you, we would greatly appreciate this.

 

Thank you everyone and sorry again for the longevity of this issue.

 

What driver versions are you running? 

 

I observed these issues with 417.11. I can try 418.81 which is the latest version. I can send files over if it is helpful. This is on a fresh install on a standard SATA 6GB/s SSD, RTX 2080 with slight overclock, i7-7700K @ 4.5ghz, 16GB of RAM @ 3.2ghz. I am not thermal throttled on anything and the hardware on either CPU nor GPU gets anywhere close to full utilization. I am using the exclusive fullscreen launch option also. 

 

With Special K (same guy who made DSFix for Dark Souls 1) frames go from like 30-80fps in busy maps like Queen's Berth @ 1440p to 80-100fps+ on high/ultra. None of it fixes the stuttering, but the FPS is higher. Seems confusing if you are not experiencing stutter considering how many people here and on reddit are experiencing the stuttering behavior. To make this clear, the FPS will stay at whatever it is capped at more or less (100 is what I keep it to), but occasionally there will be a frame stutter for around 300 ms.

 

You can either use a hardware monitor or the Special K overlay to show you at what times the frame stutter occurs and for how long it persists for. The overlay has a chart also that demonstrates when the stutter occurs. 

 

Stutter appears to be more frequent when there are many actors on the screen and it "feels" like it occurs more frequently when using Fast Mode, but I can't say for sure because I haven't logged anything. 

Edited by stackedmidgets
Link to comment
Share on other sites

  • 0

A question for you and others: are you using the unity console? I am and based on someone else's recommendation I tried disabling it, which seemed to fix the problem. In fact it seems like even just hiding it (ctrl-f8) fixes my stuttering.

 

A screenshot without the unity console running: https://pasteboard.co/I081wIm.png

 

Framerate is smooth and consistent at 13 ms/frame or roughly 80 frames/sec.

 

Screenshot with console minimized but running: https://pasteboard.co/I07V51Wb.png

 

Same 13 ms/frame base but spikes to 45 ms/frame regularly roughly every second, while roughly every ten seconds I get a much more noticeable spike up to ~300 ms/frame, the second spike in this graph.

 

I tried installing specialK to see if it helped, doesn't seem to make any difference (I'm on an older i5-3570 so only 4 cores anyway), just using it here since it displays the framerate nicely. I still get the occasional spike or stutter even with the console hidden but not nearly as often or as regularly as with it visible even minimized. Now of course if this problem can be traced back to the unity console it's not Obsidian's responsibility to fix it but it is interesting that something they changed in the patch may have made it worse.

Edited by arkteryx
Link to comment
Share on other sites

  • 0

Do you get the same 50 ms/frame microstutters every second or so? I get them every so often even with the console disabled, maybe once every 10 or 15 seconds, but with it enabled they occur like clockwork every second, see every spike but the second (which is the 300 ms spike) in the second screenshot. Do you have the unity console installed at all? Or just hidden?

Link to comment
Share on other sites

  • 0

Do you get the same 50 ms/frame microstutters every second or so? I get them every so often even with the console disabled, maybe once every 10 or 15 seconds, but with it enabled they occur like clockwork every second, see every spike but the second (which is the 300 ms spike) in the second screenshot. Do you have the unity console installed at all? Or just hidden?

 

No. The big stutters are intermittent and only frequent (under every 20 seconds or so) in the busy maps, with other maps like small dungeons barely stuttering at all. No unity console at all. No mods or plugins besides Special K.

Link to comment
Share on other sites

  • 0

It's not a matter of nvidia card or anything. I tried the game on several different machines: MacBook Pro with intel GPU, i7 3770k + NVIDIA GTX 660Ti + 16 GB RAM, i7 3770k + NVIDIA GTX 1070 + 16 GB RAM and finally Ryzen 5950x + NVIDIA RTX 3080 + 64 GB RAM . On slower GPUs I was starting at 20-60 FPS, with Ryzen + RTX 3080 I started with 100-140 FPS and they were gradually dropping down to around 30 FPS. Restarting the game brings FPS back up to the initial value and then during the first hour of playing FPS slowly plummets down to 20-30 again. Nothing helps (reducing graphics in settings etc), no hardware helps. I think there is no way in the world to run this game and have enjoyable experience on any kind of hardware in the world at the moment.

Edited by Laelaps
missed card spec
Link to comment
Share on other sites

  • 0

I just checked today with the latest Special K mod (https://discourse.differentk.fyi/). It helps to get 20-30 FPS more just when the game starts, but it does not resolve the issue with dropping FPS over time. So there is something at least.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...