Jump to content
  • 1

Lord Admiral Imp Bounty



15 answers to this question

Recommended Posts

  • 0

Since you're doing Dessiral's bounties, a quick heads-up: the Katrenn bounty in Sacred Stair suffers from the exact same issue, but it's much worse because her bodyguards like to cook bystanders in AoE fire.


Either take her out by herself and run or try to lure the group to a place where there are no NPCs (which may be somewhat harder).

Edited by Skazz
Link to comment
Share on other sites

  • 0

Oops, I just posted about this issue above (I even looked to make sure there wasn't a thread and somehow missed this).


For me, it happens every single time I attempt the fight in turn-based mode, and it doesn't seem to trigger as a result of anything attack-related. In fact, a couple of times I've tried it the guards come dashing in from off-screen, where I don't even think it would've been possible for one of them to get hit. It is...not great. I'm on about my 12th attempt to no avail.

Link to comment
Share on other sites

  • 0

I'm at this quest too.

First tried Katrenn, then skipped her to come back later (with the alternative of waiting for her at the west entrance).


But, I got this very same problem with the imp.

And, actually, when people say no AOE spell, they mean it, this includes buff spells as well.

In a fight the 1st thing I do is a +might buff with Xoti.

Reloaded, did not do the buff, and the guards did not aggro.

I could use disintegrate from Serafen though (which is a single target spell).


So, just use weapon, single target, attack (I did not try with AOE weapon attack, this may also trigger the guards) or single target spells.


[Edit] For Katrenn, the automatons do AOE spells. So did her with waiting to the west up to 8PM, clicked her to start conversation, wait the automatons exit the screen, choose attack. But still, do not do any AOE spells (even buff).

Edited by Imarion
Link to comment
Share on other sites

  • 0

This is a bug that should be fixed or relocate them where is less agro from the guards!

Trial of Iron

Path of the Damned

This is much harder with everything buffed and can't complete it!


The guards also agro if you decide to take out the group pressuring Bertenno for payment in "Velvet Glove, Brass Fist" quest.

Link to comment
Share on other sites

  • 0

Can confirm that this is still bugged, and a huge pain in Turn-Based. You can engage the imps while the guards aren't there ... but since you're stuck in turns and the guards aren't, they keep patrolling, and will eventually walk back to your area, and as long as they are nearby, they seem to have a random chance to start attacking you.

EDIT: I did finally manage to pull it off, placed my group on the bridge above and ran the enemies toward me. However, while there, a Wealthy Gentleman NPC spawned on the bridge and immediately called for the guards while he cowered. Fortunately none of them heard him. So my guess is ... certain NPCs wandering around are the culprits which trigger the guards?

Edited by Korica
Link to comment
Share on other sites

  • 0

Ok I'm stuck on the imp fight too in turn based because I always aggro the whole town's guards...

I thought turn based was out of beta ?

How such obvious bugs can still be there ?

People have been reporting this since January !


Even worse if that issue occures on other fights too apparently...

Obsidian, please !

Edited by SenSx
Link to comment
Share on other sites

  • 0

I've been reloading 10 times that fight, and each time guards become hostile for no real reason.

If every fights in the cities are bugged like that in turn based, I'm just giving up this game.

What's wrong with you Obsidian ? Letting such a huge bug plagging the game ?

And why am I not seing more complains about that ? Every one praising turn based...that's the kind of issues that make it unplayable...


Last time I'm backing your game Obsidian, poor poor support, complete disrespect for your customers and fans.

Link to comment
Share on other sites

  • 0

Unfortunately yes, this is still very much an issue. I managed to beat Lord Imp without issues, but I can;t go through the encounter in Sacred Stairs without aggroing entire city. It is strange, as guards do seem to ignore you know most of the time, and hostile nemies usually seem to come from outside my range. In case Obs would still consider looking into this issue here is a save:



PS. Alright. I managed to finish both fights. In 5.0 guards don't seem to get involved in the fights by themselves anymore, however, civilians are an issue. When a civilian walks into the fight he panics and calls for help. That can get attention of guards and if they spot you they become hostile. I believe that using laud abilities invreases chances of attracting civilians from afair - at least the attempt which succeded made me slog through the fight while using weapons and abilities with laud casting, but quiet finish, as enemies were closer to guards and civilians as my party was.

With Imps it was a simple matter of fighting on the pier, as far away from crowds as possible. In Sacred Stairs I lured enemies down the stairs near the enterance to catacombs:

The plaze in the middle is the danger zone. It sucks that the issue wasn't fully solved, but at least it is beatable. 

Edited by Wormerine
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...