Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

NWN2 autoupdater hell


  • Please log in to reply
6 replies to this topic

#1
lewwy

lewwy

    (0) Nub

  • Members
  • 1 posts
Hi all,

Recently I bought NWN2 for a good RPG to play with me and my mates. I bought a copy and installed it on 3 seperate PC's and got the cdkey in use yadda yadda yadda error. Fair enough, I went and bought another 2 copies of the game with keys etc from ebgames to play (fully uninstalled the game and reinstalled with new keys).

I then ran the autoupdater on my PC, which updated me to the latest version of NWN2. I also told my buds to run this autoupdater on their PC's to bring the game up to the latest version. This is where my trouble is.

Basically, neither one of them can update at all, it updates to the SoZ updater, and then says that they are at the latest version of 1.04 (or something) and stops the update. We spent 3 hours on it last week trying to get it to autoupdate, no dice.

What the issue seems to be is that in the autoupdate window:

Your game version is: 1.23.1763 English

Pinging: nwn2patch.obsidianent.com
Retrieving autopatcher version information
Connecting...nwn2patch.obsidianent.com
Downloading nwn2_pc_autopatch.txt
Retrieving game patch information
Connecting...nwn2patch.obsidianent.com
Downloading nwn2_pc_english.txt
Latest Game Version Available: [
You are up to date. No patch file required.
Time taken to patch game 0:00:08
Checking for additional content.
Connecting...nwn2patch.obsidianent.com
Downloading nwn2_pc_english_optional_content.txt
There is no new content available for download.
Done

Why is there a [ in where the latest game version is? That doesnt look right to me. Its like the autoupdater cant parse the update info.

#2
Walsingham

Walsingham

    Obsidian VIP

  • Members
  • 5594 posts
  • Location:The drawing room of Lady Muldoon's residence one morning in early spring
  • Backer
  • Kickstarter Backer
I'm no techie, but buying three copies and spending hours on it means you get my support. Come on, boffins!

#3
Kelverin

Kelverin

    (7) Enchanter

  • Members
  • 913 posts
  • Location:San Diego

Your game version is: 1.23.1763 English

That's the latest patch, you are up to date it look like at least that is the version I have going. ???

1.04 is the auto patch version

#4
Humodour

Humodour

    Arch-Mage

  • Members.
  • 3563 posts
The auto-updater is the worst part of the game.

Which is almost a good thing if you think about it really hard.

#5
Deadly_Nightshade

Deadly_Nightshade

    Vampire

  • Members
  • 5011 posts
  • Location:Stygia
  • Backer
  • Kickstarter Backer
I always update the files myself, without the auto-patcher. It's much faster and less error prone. :)

#6
Starwars

Starwars

    Arch-Mage

  • Members
  • 2216 posts
  • Location:Sweden
  • Silver Backer
  • Kickstarter Backer
Then I'll go against the stream and say that I have never, ever had any problems updating through the autopatcher.

As for the OP, yes, it looks like you're up to date.

#7
TrueNeutral

TrueNeutral

    (8) Warlock

  • Members
  • 1174 posts
  • Location:Просто
  • Steam:funderbunk
Funnily enough, I thought the autopatcher was discontinued because it always tells me it can't connect.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users