Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

"How To" KOTOR 2 On Vista


  • Please log in to reply
149 replies to this topic

#61
babydol

babydol

    (4) Theurgist

  • Members
  • 315 posts
  • Location:God's nowhere
  • Xbox Gamertag:tehprincessj

KotOR2 doesn't work on laptops, because it wasn't written to. A few people may have managed to get it to work, but still a lot of people who come here with laptop issues never get them resolved, even laptops than can play seemingly more demanding games. If you have a laptop, you don't meet the minimum requirements, I'm afraid.


Erm... Guess I'm just lucky then, cuz I've never had any problems. Actually runs better on my laptop then my hubby's desk top computer. :lol: Also ,(doi) with Vista.

#62
Gorth

Gorth

    Global Moderator

  • Global Moderators
  • 9695 posts
  • Location:Australia

KotOR2 doesn't work on laptops, because it wasn't written to. A few people may have managed to get it to work, but still a lot of people who come here with laptop issues never get them resolved, even laptops than can play seemingly more demanding games. If you have a laptop, you don't meet the minimum requirements, I'm afraid.


Erm... Guess I'm just lucky then, cuz I've never had any problems. Actually runs better on my laptop then my hubby's desk top computer. :lol: Also ,(doi) with Vista.

I think it might be an impression that people get because of the number of laptops with Intel gfx chips out there. People with ATI or Nvidia gfx in their laptops are better off as a rule of thumb. Even then, there are some quirky laptops out there when running the old Aurora Engine based games :-

#63
MrMidas

MrMidas

    (1) Prestidigitator

  • Members
  • 22 posts
"Original disc can not be found or authenticated"

Ran fine for a day or two :)

Im not sure i had the whole "run as admin" thing right.

Apologies for lots of questions. I should be set now once it gets up and running again :).

Edited by MrMidas, 31 August 2008 - 02:11 AM.


#64
Bass-GameMaster

Bass-GameMaster

    (5) Thaumaturgist

  • Members
  • 516 posts
  • Location:Houston, Texas
  • Xbox Gamertag:Exiied Force
If your getting a disc error you might have to contact SecuRom for a new exe..

#65
Bass-GameMaster

Bass-GameMaster

    (5) Thaumaturgist

  • Members
  • 516 posts
  • Location:Houston, Texas
  • Xbox Gamertag:Exiied Force
Err... bam?

#66
omnipace

omnipace

    (0) Nub

  • Members
  • 1 posts
SOLUTION TO KOTOR AND KOTOR 2 RANDOM CRASHES, STARTUP CRASHES AND DRIVER STOPPED RESPONDING PROBLEM IN VISTA WITH NVIDIA DRIVERS :

This worked for me like a charm and took hours to solve the problem, but the game runs wonderful now without any crashes. (Just don't alt-tab while playing, the game doesn't like it.) Please note that I worked in a non-patched version of the game. But even with the patch there should be no random crashes except the game's original bugs.

PART 1 : INI file

Go to c:\program files\lucasarts\kotor2 and move swkotor2.ini to desktop, be sure the graphic options part is as follows :

[Graphics Options]
RefreshRate=60
Height=768
Width=1024
V-Sync=0
Anisotropy=8
Frame Buffer=0
Anti Aliasing=4
Texture Quality=2
Grass=1
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=0
FullScreen=0

Sound options are as follows :


[Sound Options]
Number 3D Voices=16
Number 2D Voices=24
2D3D Bias=1.00
Force Software=1
EAX=0
Sound Init=0
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Disable Sound=0

After editing the file if required, remove it back to c:\program files\lucasarts\kotor2 folder.

PART II : NVIDIA Control panel

Go to your desktop right click and open NVIDIA control panel, now to the manage 3d settings and select global settings, change it as follows :

Anisotropic filtering : 16x
Anti-gamma : On
Antialias mode : App-cont
" - transparency : supersampling
Conformant text clamp : Use hardware
Err rep : Off
Ext. limit : off
Force mipmaps : Trilinear
Max. prerendered frames : 8
Multidisp/mix GPU : Single performance
Tex-filtering neg. bias : Clamp
Tex-filt. quality : High Q
Thread opt : off
Trip buffer : off
Vsync : force off

PART III : Registry setup

Click start, click start search, type regedit, run it. Search for "_swkotor.exe" (without commas). For me there were 3 entries and one of them is like :

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ass\{4D36E968-E421-11DE-BFC1-08002BE10318}\0000]

Under this folder, you will find _swkotor.exe entry. All entries must be REG_BINARY.

Check and add these entries :

_swkotor2.exe:D3D_16579523 01 00 00 00
_swkotor2.exe:D3D_30913648 01 00 00 00
_swkotor2.exe:D3D_60461791 47 67 41 08
_swkotor2.exe:D3D_94118636 00 00 00 00
_swkotor2.exe:D3DOGL_03385531 02 00 00 00
_swkotor2.exe:D3DOGL_12677978 60 16 62 51
_swkotor2.exe:D3DOGL_67207556 11 00 00 00
_swkotor2.exe:D3DOGL_70835937 27 00 32 22
_swkotor2.exe:D3DOGL_74095213 10 00 00 10
_swkotor2.exe:OGL_25631692 02 00 00 00
_swkotor2.exe:OGL_DefaultSwapInterval ff ff ff ff
_swkotor2.exe:OGL_ExtensionStringVersion 00 00 00 00
_swkotor2.exe:OGL_TexClampBehavior 00 00 00 00
_swkotor2.exe:OGL_ThreadControl 02 00 00 00
_swkotor2.exe:OGL_TripleBuffer 01 00 00 00

: D (with no gap changes to smile)

Close the registry editor, restart your computer and goodbye crashes... I believe OGL_ThreadControl is the critical point here. But to be sure I write all entries. Also changing all _swkotor2.exe entries to _swkotor.exe solves kotor 1 crashes, you may add them as seperate entries.

Also I changed my swkotor.ini file as follows :


[Graphics Options]
V-Sync=0
Anisotropy=8
Frame Buffer=0
Anti Aliasing=4
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=0
FullScreen=0
RefreshRate=60
Width=1024
Height=768

PART IV : Bad TDR, Bad TDR...

This is an application for graphics drivers. When a driver stops responding, vista resets the device driver so the system continues stable. But the problem is old games sometimes stops responding naturally and vista thinks the game crashed. There is a fix for that problem incase your problem consists of this :

start regedit and go to [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Gr aphicsDrivers], add a new REG_DWORD entry as

TdrDdiDelay 120
TdrDelay 60

Close regedit.

PART V : RESTART YOUR COMPUTER

Somehow these changes requires restarting the computer to take effect.

PART VI : PLAY YOUR GAME AND SAVE OFTEN INCASE

Start your game in SP2 compability mode. Old mss32.dll is required also.

The game starts in windowed mode, but when you changed the resolution from the graphic options, it turns to fullscreen.

You should try turning on frame buffer effects and shadows as well from the ini file (Just set them to 1). I didn't care so I didn't try. But you may if it is important for you.

The game is also buggy and rarely crashes to desktop after these settings so save often. Good game although, or may be best...

RESULT : NVIDIA Drivers somehow sucks...

PART VII : LAST RESORT

Change your vista theme to classic to turn off windows aero subsytem. Also close the sidebar. As an option use CPU-control program and direct all processes to CPU1 incase you are using dualcore cpus.

Edited by omnipace, 13 September 2008 - 09:24 AM.


#67
The Architect

The Architect

    (9) Sorcerer

  • Members
  • 1370 posts
  • Location:Western Australia
Thanks man! I was having trouble installing KotOR2 but thanks to your instructions I managed to install it. I appreciate it.

#68
GaspardDeadlyAssailant

GaspardDeadlyAssailant

    (3) Conjurer

  • Members
  • 160 posts
  • Location:Shangri La

KotOR2 doesn't work on laptops, because it wasn't written to. A few people may have managed to get it to work, but still a lot of people who come here with laptop issues never get them resolved, even laptops than can play seemingly more demanding games. If you have a laptop, you don't meet the minimum requirements, I'm afraid.


Erm... Guess I'm just lucky then, cuz I've never had any problems. Actually runs better on my laptop then my hubby's desk top computer. :) Also ,(doi) with Vista.

Ummm yea it works on laptops mine works more than perfactly

#69
Nole4694

Nole4694

    (0) Nub

  • Members
  • 1 posts
  • Xbox Gamertag:Nole4694
this will be my first (and probablly last) post. Thankyou so much, I found the game again just last week and I tried installing it on my new computer but it wouldnt work. I had lost all hope when I found this. again thankyou. :*



P.S. The first Kotor seemed to work fine without any of this how odd.:ermm:

#70
Bass-GameMaster

Bass-GameMaster

    (5) Thaumaturgist

  • Members
  • 516 posts
  • Location:Houston, Texas
  • Xbox Gamertag:Exiied Force
Yeah, sorry im late but your welcome.

#71
Kooky

Kooky

    (0) Nub

  • Members
  • 1 posts
Hey I tried this only I did it wit hthe game already installed and now I cannot uninstall the game. What am I supposed to do now?

#72
CorporalAris

CorporalAris

    (0) Nub

  • Members
  • 2 posts
  • Xbox Gamertag:Corporal Aris
Okay, I have followed the instructions to the letter, Opening Disk 1, going to Setup.exe's Properties, changing compatibility to both XP (SP2) and Win2000. All files on my computer are set to run as Administrator as I have turned off UAC, but I still clicked to run as Administrator. The Install Wizard pops up, then a second later, an Error pops up that says, "Setup.exe Has Stopped Working."

What is going on?

My specs are not the problem, but are as follows:
Intel C2D E7200
Windows Vista Ultimate x86 (32bit)
nVidia evga 9600GSO
4GB RAM
120GB HDD

Help would be nice.

Thanks in advanced,
--CorporalAris

#73
CorporalAris

CorporalAris

    (0) Nub

  • Members
  • 2 posts
  • Xbox Gamertag:Corporal Aris
Still waiting...
--CorporalAris

#74
jonjon

jonjon

    (0) Nub

  • Members
  • 1 posts
What a life saver!

You're a star Bass-Games Master, thanks. :thumbsup:

I just bought a new pc... (yep, vista) and couldn't get this to work on the new machine until I read your post.

It kept telling me my graphics were the problem even though I have a HD 4870 1GB and the drivers are bang up-to-date.

Cheers.

#75
Kodiackk

Kodiackk

    (0) Nub

  • Members
  • 1 posts
Ok, i think i've tried everything now but i keep getting the same message
"Runtime Error"
Program: C:\Program Files\LucasArts\SWKotOR2\swkotor2.exe
Abnormal program termination

it also tells me my graphics card is out of date
NVIDIA GeForce 7300 LE
ive downloaded several drivers that havent worked either

what can I do before I loose my mind?

#76
Bass-GameMaster

Bass-GameMaster

    (5) Thaumaturgist

  • Members
  • 516 posts
  • Location:Houston, Texas
  • Xbox Gamertag:Exiied Force
Sorry about my delayed response. Corporal, Could you provide a screenshot? Im unfamiliar with this error.

#77
Bass-GameMaster

Bass-GameMaster

    (5) Thaumaturgist

  • Members
  • 516 posts
  • Location:Houston, Texas
  • Xbox Gamertag:Exiied Force

SOLUTION TO KOTOR AND KOTOR 2 RANDOM CRASHES, STARTUP CRASHES AND DRIVER STOPPED RESPONDING PROBLEM IN VISTA WITH NVIDIA DRIVERS :

This worked for me like a charm and took hours to solve the problem, but the game runs wonderful now without any crashes. (Just don't alt-tab while playing, the game doesn't like it.) Please note that I worked in a non-patched version of the game. But even with the patch there should be no random crashes except the game's original bugs.

PART 1 : INI file

Go to c:\program files\lucasarts\kotor2 and move swkotor2.ini to desktop, be sure the graphic options part is as follows :

[Graphics Options]
RefreshRate=60
Height=768
Width=1024
V-Sync=0
Anisotropy=8
Frame Buffer=0
Anti Aliasing=4
Texture Quality=2
Grass=1
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=0
FullScreen=0

Sound options are as follows :


[Sound Options]
Number 3D Voices=16
Number 2D Voices=24
2D3D Bias=1.00
Force Software=1
EAX=0
Sound Init=0
Music Volume=85
Voiceover Volume=85
Sound Effects Volume=85
Movie Volume=85
Disable Sound=0

After editing the file if required, remove it back to c:\program files\lucasarts\kotor2 folder.

PART II : NVIDIA Control panel

Go to your desktop right click and open NVIDIA control panel, now to the manage 3d settings and select global settings, change it as follows :

Anisotropic filtering : 16x
Anti-gamma : On
Antialias mode : App-cont
" - transparency : supersampling
Conformant text clamp : Use hardware
Err rep : Off
Ext. limit : off
Force mipmaps : Trilinear
Max. prerendered frames : 8
Multidisp/mix GPU : Single performance
Tex-filtering neg. bias : Clamp
Tex-filt. quality : High Q
Thread opt : off
Trip buffer : off
Vsync : force off

PART III : Registry setup

Click start, click start search, type regedit, run it. Search for "_swkotor.exe" (without commas). For me there were 3 entries and one of them is like :

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Cl ass\{4D36E968-E421-11DE-BFC1-08002BE10318}\0000]

Under this folder, you will find _swkotor.exe entry. All entries must be REG_BINARY.

Check and add these entries :

_swkotor2.exe:D3D_16579523 01 00 00 00
_swkotor2.exe:D3D_30913648 01 00 00 00
_swkotor2.exe:D3D_60461791 47 67 41 08
_swkotor2.exe:D3D_94118636 00 00 00 00
_swkotor2.exe:D3DOGL_03385531 02 00 00 00
_swkotor2.exe:D3DOGL_12677978 60 16 62 51
_swkotor2.exe:D3DOGL_67207556 11 00 00 00
_swkotor2.exe:D3DOGL_70835937 27 00 32 22
_swkotor2.exe:D3DOGL_74095213 10 00 00 10
_swkotor2.exe:OGL_25631692 02 00 00 00
_swkotor2.exe:OGL_DefaultSwapInterval ff ff ff ff
_swkotor2.exe:OGL_ExtensionStringVersion 00 00 00 00
_swkotor2.exe:OGL_TexClampBehavior 00 00 00 00
_swkotor2.exe:OGL_ThreadControl 02 00 00 00
_swkotor2.exe:OGL_TripleBuffer 01 00 00 00

: D (with no gap changes to smile)

Close the registry editor, restart your computer and goodbye crashes... I believe OGL_ThreadControl is the critical point here. But to be sure I write all entries. Also changing all _swkotor2.exe entries to _swkotor.exe solves kotor 1 crashes, you may add them as seperate entries.

Also I changed my swkotor.ini file as follows :


[Graphics Options]
V-Sync=0
Anisotropy=8
Frame Buffer=0
Anti Aliasing=4
Texture Quality=2
Emitters=1
Grass=1
Soft Shadows=0
Shadows=0
Brightness=57
EnableHardwareMouse=0
FullScreen=0
RefreshRate=60
Width=1024
Height=768

PART IV : Bad TDR, Bad TDR...

This is an application for graphics drivers. When a driver stops responding, vista resets the device driver so the system continues stable. But the problem is old games sometimes stops responding naturally and vista thinks the game crashed. There is a fix for that problem incase your problem consists of this :

start regedit and go to [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Gr aphicsDrivers], add a new REG_DWORD entry as

TdrDdiDelay 120
TdrDelay 60

Close regedit.

PART V : RESTART YOUR COMPUTER

Somehow these changes requires restarting the computer to take effect.

PART VI : PLAY YOUR GAME AND SAVE OFTEN INCASE

Start your game in SP2 compability mode. Old mss32.dll is required also.

The game starts in windowed mode, but when you changed the resolution from the graphic options, it turns to fullscreen.

You should try turning on frame buffer effects and shadows as well from the ini file (Just set them to 1). I didn't care so I didn't try. But you may if it is important for you.

The game is also buggy and rarely crashes to desktop after these settings so save often. Good game although, or may be best...

RESULT : NVIDIA Drivers somehow sucks...

PART VII : LAST RESORT

Change your vista theme to classic to turn off windows aero subsytem. Also close the sidebar. As an option use CPU-control program and direct all processes to CPU1 incase you are using dualcore cpus.





This only should be tinkered with if all else fails, editing the ini can lead to huge issues if not done right.

1 Tip: Put your Nvidia Control panel on "let the application decide"

#78
Ta Swavo

Ta Swavo

    (0) Nub

  • Members
  • 1 posts
I'd just like to say a huge thanks to Bass-GameMaster.

My son has a new PC and was forced to play on my PC because I couldn't get it working on his Vista machine.
You've allowed me to get on with what I want to do as he can now play as much as he wants without kicking me off my machine :)

Thanks again.

btw - I didn't need the securom support - it was just that DLL

#79
Bass-GameMaster

Bass-GameMaster

    (5) Thaumaturgist

  • Members
  • 516 posts
  • Location:Houston, Texas
  • Xbox Gamertag:Exiied Force
Thanks again guys, This should of been a poll to vote on a stickied thread. >_<.. Guess I can't have two.

#80
SusanStoHelit

SusanStoHelit

    (0) Nub

  • Members
  • 1 posts
  • Location:Australia
Hey, thanks heaps.

I can now run my game - replacing the Mss32.dll file worked. And I don't have to run the game as an administrator OR in XP compatability mode. >_<




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users