Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

NWN2: Technical Challenges


  • Please log in to reply
160 replies to this topic

#1
Fionavar

Fionavar

    Community Manager

  • Global Moderators
  • 10822 posts
  • Location:Manitoba, Canada
Please add your concerns/experieinces in order to help one another and also have a central local for devs to reference.

#2
Fionavar

Fionavar

    Community Manager

  • Global Moderators
  • 10822 posts
  • Location:Manitoba, Canada

Hi,
I just bought this game today and couldnt wait to get home to try it out. I've formerly played some of your games and was looking forward to a nice weekend of gaming.

Now to the problem. I installed the game, downloaded the latest patch through your downloading manager thing (version 1.01 nordic, gb? version of the game). All that went without any problems. So I thought I'd reboot my computer after the update just in case. When I got back into WinXP, I started the game with the desktop icon, pressed play game and waited. The screen went black and the DVD-ROM started buzzing a bit. After a little while, well something like 5-10secs, the DVD-ROM stopped making any noise. The screen was still black though and continued to stay so for several minutes. I lost my patience and pressed ctrl-alt-del. As i thought the game stopped responding.

I looked at some forums and found out that maybe it was my firewall and/or antivirus which was the cause. Stopped both and tried again, same thing happened. So I thought maybe it was my display drivers which were bugging, downloaded the latest from the manufacturers website(which is an older version than those I was using.) and tried again. Same result.

So I was hoping someone here could help me out, I've waited a good while for this game and I was really looking forward to spending some time in the land of D&D.

My computer is a Zepto Znote 6214W (Notebook) http://www.zepto.dk. Specs are following: Intel Core2Duo T7200@2Ghz, 2GB Kingston 667Mhz Ram, nVidia 7600 Go 512MB.

Thanks.

<{POST_SNAPBACK}>



#3
Fionavar

Fionavar

    Community Manager

  • Global Moderators
  • 10822 posts
  • Location:Manitoba, Canada

Hi Devs (hopefully),

with many others http://nwn2forums.bi...07078&forum=116, i have a problem. The popup window informing you that your video card has less than 128MB which may impair performance closes the main process if ok is clicked. Some have the problem with 128 MB dedicated or better cards, all are pixelshader 2.0.  :blink:  :ermm:

So, a simple popup info closed shuts down the whole process. Perhaps because both warning and game window have the same name in task manager ? Anyways, please change the popup handler code in the main exe or give us a workaround (e.g. explaining how registry and $username$/own files/neverwinter nights 2 have to be set up in order to avoid autodetect). Or just tell us you are working on it or something... :thumbsup:

Sajin

<{POST_SNAPBACK}>



#4
Fionavar

Fionavar

    Community Manager

  • Global Moderators
  • 10822 posts
  • Location:Manitoba, Canada

Hi all,

Like many of us i buyed the game today 03/11/06 (release today in belgium) and installed the game.  When i started it up it asked me if i wanted to run the updates.

The first one run without any truble but in the middle of the second one i get some errormessage from windows telling me the updates can't be dawnloaded and it close my gamescreen, that means i can't join any server to play the game, only the single player modes work.

Dunno if someone can put me a link here on the site so i can try to dawnload the update from some other site and not direct from my updatebutton of the game.

Philwolf

<{POST_SNAPBACK}>



#5
Gfted1

Gfted1

    Forum Moderator

  • Moderators
  • 3694 posts
  • Location:Chicago, IL
  • Backer
  • Kickstarter Backer
OK, heres my problem:

The updater fails to work and gives me an error of "Internet is not connected or patch server is down". I know its not the former so it must be the latter. Trying to navigate directly to the download page provides a link to an FTP site that doesnt have jack on it, so I dont know whats up with that or how Im going to get the patch.

#6
Atreides

Atreides

    (11) Wizard

  • Members
  • 1743 posts
Sorry this is copy pasta, but I'm still wondering if I'll need to upgrade.

Hay guyz, I'm running on an AMD Sempron™ 2400+, 1.667 GHz. I failed the CPU (internet test compatibility) check because it's saying I'm running a 1.667 Ghz CPU which is below 2 Ghz.

But I'm on a 2400+. Can I run the game?



#7
LordMothman

LordMothman

    (0) Nub

  • Members
  • 1 posts
The copies of the game that shipped to Greece have another problem. The EXE file is missing, so after the installation and the update the game doesn't run at all.
Onlythe installer is on the disk....

#8
kirottu

kirottu

    Animeholic

  • Members
  • 4083 posts
  • Location:Finland
  • Backer
  • Kickstarter Backer

The copies of the game that shipped to Greece have another problem. The EXE file is missing, so after the installation and the update the game doesn't run at all.
Onlythe installer is on the disk....

<{POST_SNAPBACK}>


:lol:

Now thatīs a screw up! I feel like I should congratulate someone at atari, but I donīt know who. :p

#9
Hassat Hunter

Hassat Hunter

    Royal Bug Catcher of the Obsidian Order

  • Members
  • 4944 posts
  • Location:Out there, somewhere...
  • Backer
  • Kickstarter Backer
How does one update the game without the game EXE? :lol:

#10
philwolf

philwolf

    (1) Prestidigitator

  • Members
  • 6 posts
hmmm,

not even a single official reaction.... :lol:

personaly i find this a lack of respect to all gamers who buyed the game and are stucked in the single players mode and not able to join any server. :p

I payed arround 50 euro's for a single mode game...... and seriously hope one day we all will be able to join the servers arround.

Maybe it should have be simpler to release the game one month later to fix all buggs before selling this game.
Not sure who to blame but ... realy it sucks :wacko:

Philwolf

#11
Diamond

Diamond

    (10) Necromancer

  • Members
  • 1454 posts
Try Atari NWN2 support forums or Bioware NWN2 forums, which seem to be the major place for official answers these days.

#12
Jorian Drake

Jorian Drake

    Arch-Mage

  • Members
  • 2562 posts
  • Location:1st of the Sector IX.B - Via Crucis

Try Atari NWN2 support forums or Bioware NWN2 forums, which seem to be the major place for official answers these days.

<{POST_SNAPBACK}>

I hope F didn't make this thread only to bump the thrash somewhere :shifty:

#13
Gfted1

Gfted1

    Forum Moderator

  • Moderators
  • 3694 posts
  • Location:Chicago, IL
  • Backer
  • Kickstarter Backer
My problem was solved! If any of you are having the same patch update problem as me, go here. You will find patch links for English, French, Italian and German.

#14
Fionavar

Fionavar

    Community Manager

  • Global Moderators
  • 10822 posts
  • Location:Manitoba, Canada

My problem was solved! If any of you are having the same patch update problem as me, go here. You will find patch links for English, French, Italian and German.

<{POST_SNAPBACK}>


Thanks Gfted1! Hopefully this will hellp others.

#15
Wistrik

Wistrik

    (5) Thaumaturgist

  • Members
  • 560 posts
Those who try to run this game on a widescreen monitor may experience a mouse pointer glitch like I did. The glitch didn't manifest when switching between non-widescreen video resolutions. I'll explain the glitch and how I solved it.

I switched to 1680x1050 (my screen's max resolution). Suddenly my mouse pointer didn't line up with button hotspots. In other words, to click a button I'd either have to move the mouse two inches below the button or two inches to the right of it in order to click it.

The fix is to ALT-TAB, minimizing the game, then return to the game. The screen will re-render and the mouse pointer glitch will be gone.

This glitch only manifests when switching from a non-widescreen mode to widescreen, not when going the other way.


Update: This is caused when NVidia's flat-panel scaling is activated. Apparently it conflicts with the game's own scaling and causes the mouse pointer to behave strangely.

Edited by Wistrik, 04 November 2006 - 04:22 PM.


#16
Wistrik

Wistrik

    (5) Thaumaturgist

  • Members
  • 560 posts
It is stated twice on page 23 in the manual that, unlike in D&D, you don't have to spend skill points when leveling up, but can save them for later use. This is not true in NWN2 (it was for NWN); NWN2 won't activate the NEXT button until skill points are spent.

The readme containing last-minute manual corrections does not modify this text.

#17
Deraldin

Deraldin

    Arch-Mage

  • Members
  • 4028 posts
  • Location:Somewhere cold
  • Gold Backer

It is stated twice on page 23 in the manual that, unlike in D&D, you don't have to spend skill points when leveling up, but can save them for later use. This is not true in NWN2 (it was for NWN); NWN2 won't activate the NEXT button until skill points are spent.

The readme containing last-minute manual corrections does not modify this text.

<{POST_SNAPBACK}>


Are you sure you can't save them? Or is it just that you can't save all of them? I know there has been at least once where I have missed increasing one skill on level up only to discover it at the next level. :geek:

#18
Spider

Spider

    Arch-Mage

  • Members
  • 2126 posts
  • Location:Sweden
  • Silver Backer
  • Kickstarter Backer
You can save 5 skillpoints between levels.

#19
Shinwar

Shinwar

    (0) Nub

  • Members
  • 3 posts
Will Patch 1.02 Fixes the bug of the window "128MB Video RAM"......

#20
Ummi

Ummi

    (3) Conjurer

  • Members
  • 126 posts
  • Location:Estonia
I had two problems. I'll post them with solutions so that people who experience similar problems know what to do about them.

1. I couldn't get 5.1 sound to work and the game would configure my speaker settings to 2.1 whenever i started it. Solution: go to nwn.ini and modify value of Speaker Type to 4.

2. Shadows flicker horribly with certain ATI video cards. My card is 1950 XTX and other 1900 XTX users had the same complaint on NWN2 boards. Current solution: None other than turning off shadows :*




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users