Jump to content

Welcome to Obsidian Forum Community
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Crash after first cutscene; Radeon 7500


  • Please log in to reply
18 replies to this topic

#1
vlatko27

vlatko27

    (1) Prestidigitator

  • Members
  • 9 posts
OK, here is the stuff I tried out and did not work:

- Cats 4.1, 4.11, 4.2, 5.1, 5.2
- Omega (Cats 5.1)
- removed wnaspi32.dll from my system32 folder

Is there anything else I can try out or am I forced to wait for the dreaded patch?

I heard something about emulating T&L on my card, any tips on that?

Thanks,

CPU: 1.2 GHz
RAM: 512 Mb
Radeon 7500 64 Mb (Old I know but Kotor worked like a charm)
Windows XP Professional SP2

#2
Arturo

Arturo

    (1) Prestidigitator

  • Members
  • 25 posts
Radeon 7500 is not supported..... check the readme.


Saludos.-

#3
vlatko27

vlatko27

    (1) Prestidigitator

  • Members
  • 9 posts

Radeon 7500 is not supported..... check the readme.


Saludos.-

<{POST_SNAPBACK}>


I read the readme but the games have the same engine and I think people with supported cards have the same problem. so...

#4
wumasta420

wumasta420

    (0) Nub

  • Members
  • 3 posts
I've got a Radeon 7500 and frankly i'm upset it doesn't work on my computer either since the first one played fine. The problem is the hardware of the 7500 doesn't do some opengl 1.4 functions. While they could have programmed around this fact, because they're lazy they didn't. So the only solution would be if ATI puts out a new driver that fixes the problem, which I don't think will happen. Or if Obsidian puts out a patch that fixes the problem, which I also don't think will happen bc they put it on the list of unsupported cards. Or the last possibility is if there's an opengl 1.4->directx wrapper, the only one i could find was gldirect, but I couldn't get it to work with the game.

This is the ONLY game i've ever seen that supports radeons but not the 7500, which is a little ridiculous since the card is still pretty widely owned.

#5
JamieKirby

JamieKirby

    (6) Magician

  • Members
  • 640 posts
and pretty old.....

i have noticed that the game goes to a black screen on mine when i use 4.11 with 4.3 version of the [atioglxx.dll] file. (for the glow thing to work on my ATI card)

But without the [atioglxx.dll] file, it worked fine....so if you are doing that, try it without the file in the Kotor II main directory.

#6
Kiwegapa

Kiwegapa

    (4) Theurgist

  • Members
  • 209 posts
  • Pillars of Eternity Gold Backer
  • Kickstarter Backer
  • Deadfire Backer

Radeon 7500 is not supported..... check the readme.

I read the readme but the games have the same engine and I think people with supported cards have the same problem. so...


Unfortunately, they updated something in KOTOR 2 and now the game needs OpenGL 1.4 hardware support on ATI cards. The game might run, but until we find a better solution, it won't run well.

Sorry.

#7
vlatko27

vlatko27

    (1) Prestidigitator

  • Members
  • 9 posts

I've got a Radeon 7500 and frankly i'm upset it doesn't work on my computer either since the first one played fine.  The problem is the hardware of the 7500 doesn't do some opengl 1.4 functions.  While they could have programmed around this fact, because they're lazy they didn't.  So the only solution would be if ATI puts out a new driver that fixes the problem, which I don't think will happen.  Or if Obsidian puts out a patch that fixes the problem, which I also don't think will happen bc they put it on the list of unsupported cards.  Or the last possibility is if there's an opengl 1.4->directx wrapper, the only one i could find was gldirect, but I couldn't get it to work with the game.

This is the ONLY game i've ever seen that supports radeons but not the 7500, which is a little ridiculous since the card is still pretty widely owned.

<{POST_SNAPBACK}>


yeah the card isn't that bad, I played tons of new games on it, I don't have to play the game with high detail graphics I can play it with all settings low..if it would only work with the upcoming patch.. I can't afford a new card and I am pretty sure lots of people feel the same. DO SOMETHING OBSIDIAN!!

#8
Bazooka

Bazooka

    (2) Evoker

  • Members
  • 69 posts

Radeon 7500 is not supported..... check the readme.


Saludos.-

<{POST_SNAPBACK}>


I read the readme but the games have the same engine and I think people with supported cards have the same problem. so...

<{POST_SNAPBACK}>


The games don't use the same engines..... The KotOR 2 engine is based on the KotOR 1 engine, that's true, but they changed a couple of things, and the 7500 doesn't support some of those changes.... Sorry mate, but that's the risk of ignoring system requirements....

#9
Horus

Horus

    (2) Evoker

  • Members
  • 87 posts
  • Location:The beautiful river, which my death relatives are waving, calling me at another side of shore with the spooky boatman begging me a coin for he could get me across.
Same problem here.

I just wait for a patch, whatever it could do anything to run this game.

#10
Bazooka

Bazooka

    (2) Evoker

  • Members
  • 69 posts

Same problem here.

I just wait for a patch, whatever it could do anything to run this game.

<{POST_SNAPBACK}>


If you're using a radeon 7500, a patch won't help you... the engine just won't run on that card...

#11
Kiwegapa

Kiwegapa

    (4) Theurgist

  • Members
  • 209 posts
  • Pillars of Eternity Gold Backer
  • Kickstarter Backer
  • Deadfire Backer

Same problem here.

I just wait for a patch, whatever it could do anything to run this game.

If you're using a radeon 7500, a patch won't help you... the engine just won't run on that card...

Actually, if they change the way the game engine works to have a fallback path like Half-Life 2 or Doom 3, then it'd work fine, just with uglier effects. However, I doubt they're going to do that sort of major revamp. KOTOR 2 might be the first major game to fail to support a 7500, but it won't be the last. as the card continues to get older.

#12
swaaye

swaaye

    (2) Evoker

  • Members
  • 81 posts
You people have to upgrade. The 7500 is the same core as the original Radeon 256, which came out in 1999-2000. That sucker is a bit too old now, I'm sorry. Asking Obsidian to make their engine run on it, when they specifically state they do not support it, is just not realistic.

There are several possible reasons that the GF2 is supported over Radeon 256/7x00. GF2 has better T&L performance, and a LOT more fillrate. GF2 is also a bit more capable than the Radeon 7500 with regards to texturing capabilities. The old Radeon lacks the NV15's register combiner functionality, and the old Radeon is likely to be partial to D3D since it was developed in a time when ATi was not good with OpenGL at all. I get the impression that the old Radeon's core is a bit buggy and there are things that couldn't be worked around adequately.

Unless you people can't afford to eat, you can afford a substantially better card. Here are some options:

Radeon 9000 (same as 8500/9200) $47
http://www.newegg.co...-102-386&depa=0

Radeon 9600 (lots better than a 9000) $72
http://www.newegg.co...-164-023&depa=0

(btw, stay away from LE and SE variants. They are crippled)

Or you could hit eBay and go after a Radeon 9700 and be totally good to go.
(for example) http://cgi.ebay.com/...5167578911&rd=1

#13
Kalahiin

Kalahiin

    (0) Nub

  • Members
  • 4 posts
I have the same problem. And the reason I can't afford a newer card is because my board doesn't have an AGP slot. So to get anythin newer than a 7500 I'd have to shell out for a new board AND a new card, and all the trouble that that brings.

#14
Horus

Horus

    (2) Evoker

  • Members
  • 87 posts
  • Location:The beautiful river, which my death relatives are waving, calling me at another side of shore with the spooky boatman begging me a coin for he could get me across.
*Sigh...

I'm about to buy a new desktop next year. (or when budget's ready!!)

But, for now, just hope I could experiences this game like you all could as soon as possible. I'll wait for these patches like damn old fool in the wrecked barn waiting for raining then his grain should grow.

#15
Intrama

Intrama

    (1) Prestidigitator

  • Members
  • 21 posts
  • Location:Canada.. eh
Most people I see that have the same problem I'm having (BCoD after intro movie..) are very different breeds.. graphic card wise I mean!

I've seen people with crap cards.. mediocre cards.. good cards.. and amazing cards.. ALL have the same problem.

It's not our fault guys.. and hopefully this patch lets us play this (presumably) wonderful game..

I just want to play.. even if the settings are all low.. :o

#16
vlatko27

vlatko27

    (1) Prestidigitator

  • Members
  • 9 posts

Most people I see that have the same problem I'm having (BCoD after intro movie..) are very different breeds.. graphic card wise I mean!

I've seen people with crap cards.. mediocre cards.. good cards.. and amazing cards.. ALL have the same problem.

It's not our fault guys.. and hopefully this patch lets us play this (presumably) wonderful game..

I just want to play.. even if the settings are all low.. :blink:

<{POST_SNAPBACK}>


amen..
let us fools with lousy cards hope a patch will give us a chance to play

#17
Darth Somethingorother

Darth Somethingorother

    (4) Theurgist

  • Members
  • 263 posts
  • Location:If there's a bright center to the universe, Iam in the city farthest from *cough* Liverpool *Cough*

Radeon 7500 is not supported..... check the readme.

I read the readme but the games have the same engine and I think people with supported cards have the same problem. so...


Unfortunately, they updated something in KOTOR 2 and now the game needs OpenGL 1.4 hardware support on ATI cards. The game might run, but until we find a better solution, it won't run well.

Sorry.

<{POST_SNAPBACK}>


Just a quick point; KotOR I needed OGL 1.4 as well, and if you look in the requirements.ini file in the utils folder in your KotOR2 directory, you'll see that the recommended OGL version for ATI cards appears to be 1.3, not 1.4. :)

#18
Sithmasteryoungy

Sithmasteryoungy

    (2) Evoker

  • Members
  • 99 posts
I bought a Radeon ATI 9600SE and now the game runs excellent!

#19
Horus

Horus

    (2) Evoker

  • Members
  • 87 posts
  • Location:The beautiful river, which my death relatives are waving, calling me at another side of shore with the spooky boatman begging me a coin for he could get me across.
http://forums.obsidi...03 <<< please check this thread and try anything that you could.

Oh man, shareware again... I still got problem with my credits!!!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users